403 forbidden with vhost
Posted by: tangocharlie (70.103.153.---)
Date: September 11, 2010 08:53AM

I've searched the forums, but could not find a solution that worked for me. I tried a couple of t hings unsuccessfully, and I have changed those things back.

Without Vhosts enabled I get: serves the contents of the www folder
localhosts serves the contents of the www folder
intranet serves the contents of the www folder
...and phpmyadmin works

With Vhosts I get: 403 forbidden works
localhosts/ 403 forbidden
localhosts/phpmyadmin works
intranet/ 403 forbidden
intranet/phpmyadmin works

In addition to the default install, I have also created

I'm running XP Pro, everything up to date. Default install of Wampserver 2.0i.

Because everything is default I will only list the things I have changed:

Hosts: localhost intranet

LoadModule vhost_alias_module modules/mod_vhost_alias.so
# Virtual hosts
Include conf/extra/httpd-vhosts.conf

The entire contents of the conf/extra/httpd-vhosts.conf file (without ---'s of course):
NameVirtualHost *:80

<VirtualHost *:80>
ServerName intranet
DocumentRoot "C:\wamp\www_intranet"
ErrorLog "C:\wamp\www_intranet\logs\error.log"
CustomLog "C:\wamp\www_intranet\logs\access.log" common
...and yes, the file is in the "extra" folder.

...What am I missing?

Options: ReplyQuote
Re: 403 forbidden with vhost
Posted by: yfastud (Moderator)
Date: September 11, 2010 03:26PM

Options: ReplyQuote

Sorry, only registered users may post in this forum.