Access denied for user 'root'@'localhost' (using password: NO)
Posted by: ingela (
Date: July 30, 2009 02:03PM

Please help!

First, I don't use phpmyadmin very often and is close to novise on mySQL so please forgive me if the answer to my question may be obvious to most of you.

My problems started when I tried to set a password for my root user in mySQL. I used an earlier version of WAMP then (2.0c). After that I couldn't connect to phpmyadmin even though I added the password in the file. (Received the same error as in the subject line)

Well, I decided to make a completely new installation of wamp and after uninstalling and installing (2.0i) and restarting dozens of times (with the above error inbetween) I finally got phpmyadmin to work again. However, I still didn't have a root password set so I decided to make one more try to set a password for root, and now there is NO WAY FOR ME TO MAKE PHPMYADMIN WORK! I've followed the below steps several times:

1. I've stopped all services and exited wamp,
2. used the wamp uninstall program and
3. deleted the wamp directory.
4. Restarted the computer (actually I shut down and started in two steps to REALLY restart everything)
5. Installed wamp 2.0i from scratch (again)
6. Restarted the computer (as above)
7. Tried to access phpmyadmin

and I STILL get the above error: Access denied for user 'root'@'localhost' (using password: NO)

Please help! What am I missing here? Is there anything I've missed to delete? In the registry?

If there is no password set for root (and it shouldn't be since I've logged in through MySQLconsole with a blank password) and there is no password set in (it's blank) where can this error be located and corrected?

I'm using XP SP3.

Can anyone please tell me how to make a complete new installation of wamp and all of its components? I don't care about setting a password for root anymore (At least I think so. After all, it's not online but only my local computer) I just want it to work the way it used to.

Any solution to have phpmyadmin work would be greatly appreciated!

Thanks in advance!

Options: ReplyQuote
Re: Access denied for user 'root'@'localhost' (using password: NO)
Posted by: yfastud (Moderator)
Date: July 30, 2009 02:07PM

Options: ReplyQuote

Sorry, only registered users may post in this forum.