Launching wampserver error
Posted by: gator (12.23.110.---)
Date: February 23, 2009 07:46PM


I'm a newbie, just installing wampserver.

I installed the wampserver 2.0F. When I go to run it I get an error, "an unhandled win32 exception occurred in mysqld.exe".

My machine is XP Pro SP3, running IIS5.1(not that it matters). Can't figure out anything else.

Other things about my machine are that it's running VS2005 and VS2008 with all needed .NET frameworks (1.1,2.0, and 3.5).

Anybody have any ideas on what is going on here?

Thanks in advance.


Options: ReplyQuote
Re: Launching wampserver error
Posted by: yfastud (Moderator)
Date: February 23, 2009 08:41PM

IIS and Apache/Wamp are both web server and might conflict in some way, so you have to disable IIS in order for Wamp to work

Disable IIS in Vista:

Control Panel, Uninstall Programs, Turn Widows Features On or Off, uncheck Internet Information Services

Disable IIS in XP:

Control Panel, Add/Remove Programs, Add/Remove Windows Components, uncheck Internet Information Services (IIS)

Restart computer, then restart Wamp

Also, open file hosts in folder C:\WINDOWS\System32\drivers\etc and make sure you have only this line and nothing else localhost

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS

Options: ReplyQuote
Re: Launching wampserver error
Posted by: gator (12.23.110.---)
Date: February 23, 2009 09:18PM


Thanks for the quick reply.

I tried your steps, and still receiving same message.

Another item to point out: I have MSSQL 2005 and 2000 installed ( I should have mentioned that before).

Options: ReplyQuote
Re: Update: Launching wampserver/mysql error
Posted by: gator (12.23.110.---)
Date: February 23, 2009 10:36PM


I got wampserver/mysql to start with no error, BUT, I had to install 5.0.51b for mysql. So, the latest mysql did not work for me ( Does it work for anyone else with a similar environment? Now I just have to figure out how to use it, and I'm ready to go!!!!

My question now is, where do I log the error for the greater good.

Options: ReplyQuote
Re: Launching wampserver error
Posted by: yfastud (Moderator)
Date: February 24, 2009 11:46PM

Options: ReplyQuote
Re: Launching wampserver error
Posted by: headshota23 (
Date: February 25, 2009 06:50PM

I am having the same (or similar) issue with mysqld.exe failing on startup. I am running XP and trying to install wampserver at work. I am using an older version of wamp on my laptop at home (also XP) without issue. I am new to this whole thing and have no idea where to start looking for probs. I did check the IIS and it is not running. The MySQL log states:

090225 12:09:56 InnoDB: Error: unable to create temporary file; errno: 2
090225 12:09:56 [ERROR] Plugin 'InnoDB' init function returned error.
090225 12:09:56 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
090225 12:09:56 - mysqld got exception 0xc0000005 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 133305 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x2197b30
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
00560F71 mysqld.exe!???
Trying to get some variables.
Some pointers may be invalid and cause the dump to abort...
thd->query at 00000000=(null)
The manual page at [] contains
information that should help you find out what is causing the crash.

Options: ReplyQuote

Sorry, only registered users may post in this forum.