wampapache service won't start
Posted by: sebseb (---.dsl.pipex.com)
Date: January 02, 2008 12:15PM


I have a strange problem with the apache service not starting...

I have a fresh install of WinXP SP2.
httpd.exe runs fine when started manually from the command prompt, so the conf file settings are all ok.
But when the service is started it immediately terminates. Starting the service manually gives the following message:
"Could not start the wampapache service on Local Computer
Error 1067: The process terminated unexpectedly."

There is nothing at all being written to the Apache error.log so I really don't know where to look to see what the problem is.

I've tried installations of both WampServer2.0a & wamp5_1.7.2 with a full uninstall/reboot/install in between and both have the same problem. On my other PC I have wamp5_1.7.2 running fine with the exact same files in the wamp folder.

I'm pretty much stumped as to what to do!


Options: ReplyQuote
Re: wampapache service won't start
Posted by: student101 (---.saix.net)
Date: January 04, 2008 08:24AM

I am also having some strange ass errors and problems.

Anyways, I would suggest that you backup your data like sites and mysql databases, then
remove all versions of wamp, mysql and php.

After rebooting - reload the latest version of wamp.


Options: ReplyQuote
Re: wampapache service won't start
Posted by: sebseb (---.dsl.pipex.com)
Date: January 04, 2008 03:58PM

Thanks but this is where I started: with the latest version of WampServer on a fresh install of Windows XP.

If something was written into the error.log file then at least I would know what's going on, but as it is httpd.exe just terminates immediately when run as a service (even though it runs just fine when started in the foreground).

I tried starting the service from the command prompt and this does work either..
httpd.exe -k runservice
.. just starts for a couple of seconds (can see httpd process running), then quits with nothing written to any log file.

I also tried this with same result:
httpd.exe -k start -n wampapache

And I even tried:
httpd.exe -k start -n wampapache -E errors
.. and it just creates an empty file "errors"

Very odd!


Edited 2 time(s). Last edit at 01/04/2008 04:00PM by sebseb.

Options: ReplyQuote

Sorry, only registered users may post in this forum.