Maximum execution time of 300 seconds exceeded
Posted by: dutchie (---.cable.casema.nl)
Date: December 20, 2007 04:45PM

Hello,

I'm trying to import a large mysql dump with phpmyadmin
but im am getting depreate now becasue whatever i do I keep getting the Maximum execution time error.

I have set the max_execution_time in php.ini to 1200 seconds, but this is being ignored.
(I've edited both /php/php.ini as Apache2/bin/php.ini, and even to be sure php.ini-recomended and php.ini-dist but still I get this error)

I don't know what to do next and this is really breaking my balls and driving me nuts.
( I need to import and fix this backup because I damaged the original online database)

please help
thanks

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: yfastud (Moderator)
Date: December 20, 2007 05:07PM

Change only that line won't help you to restore big db, so you have to setup some other factors as well

Try these different settings in C:\wamp\bin\apache\apache2.2.6\bin\php.ini

Find:
post_max_size = 8M
upload_max_filesize = 2M
max_execution_time = 30
max_input_time = 60
memory_limit = 8M

Change to:
post_max_size = 750M
upload_max_filesize = 750M
max_execution_time = 5000
max_input_time = 5000
memory_limit = 1000M

And add this to C:\wamp\bin\mysql\mysql5.0.45\my.ini:

max_allowed_packet = 200M

Then restart wamp

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS
FREE WAMP Guides

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: dutchie (---.cable.casema.nl)
Date: December 20, 2007 05:55PM

Hi

I followed your instructions, but still the error

Fatal error: Maximum execution time of 300 seconds exceeded in C:\serv\phpmyadmin\libraries\string.lib.php on line 69
(I did not forget to restart apache)

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: yfastud (Moderator)
Date: December 20, 2007 06:25PM

Quote

C:\serv\phpmyadmin\libraries\string.lib.php
It seems you don't use wamp, so make sure you edit the right php.ini associated w/ it

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS
FREE WAMP Guides

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: dutchie (---.cable.casema.nl)
Date: December 20, 2007 06:41PM

No, I do use Wamp server, only the folder where it is installed is called 'serv' (for no particular reason).

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: yfastud (Moderator)
Date: December 20, 2007 06:43PM

If so, try to increase those numbers if your db is way too big

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS
FREE WAMP Guides

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: dutchie (---.cable.casema.nl)
Date: December 20, 2007 07:32PM

After setting every instance of max_execution_time to 5000, how come the error message keep saying that the MAX is 300 seconds?

The size of the sql dump is around 17.5 MB, compressed nearly 5MB, it's large but not really huge.



Im now at the point that I almost wanna trow my laptop out the window sad smiley

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: yfastud (Moderator)
Date: December 20, 2007 08:32PM

Don't throw it away, just give it to me; he he... he he... just kidding ;-)

From you error, again just make sure you edit the right php.ini; also, try this:

First, search you computer to see how many php.ini you have, and eliminate the extra oneespecially if it's in windows folder since it's the first place apache will look for php.ini

Second, try to clean browser cache since sometimes browser still getthe old info from old cache

If it still not help, then try mysql bigdump or mysqldumpper; they both have same concept that cuts your big db into sections/small pieces and keep import them until finish

[www.ozerov.de]
[mysqldumper.de]

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS
FREE WAMP Guides

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: dutchie (---.cable.casema.nl)
Date: December 20, 2007 11:45PM

thanks for all your help yfastud.

I gave up on the settings and imported the db with BigDump

Now I've spend the whole day making it possible to fix yesterday's error
(think i'm now going to turn on the TV for a change)

thanks again and have a good evening.!

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: yfastud (Moderator)
Date: December 21, 2007 01:42AM


Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: orjtor (---.mobileonline.telia.com)
Date: September 11, 2009 08:44AM

Hi,

I have a similar problem when I want to import a 13MB sql file with phpMyAdmin.
I get the error:
"Maximum execution time of 300 seconds exceed
in C: \ wamp \ apps \ phpmyadmin3.2.0.1 \ library \ db \ mysql.dbi.lib"

I have a fresh copy of wampserver and the addon PHP 5.2.8 running.

I have made the above changes in php.ini and my.ini and restarted all services.

Where does these "300 seconds" come from?

Thanks
/Örjan

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: toumimi (84.6.111.---)
Date: September 11, 2009 08:52AM

So, what did you do ?
What about post 2 of this thread ?

Florian

WampServer Patch (Screenshots)
Topic EN : www.wampserver.com
Topic FR : www.wampserver.com

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: orjtor (---.mobileonline.telia.com)
Date: September 14, 2009 10:02PM

Hi,

I've made the following changes:
post_max_size = 750M
upload_max_filesize = 750M
max_execution_time = 5000
max_input_time = 5000
memory_limit = 1000M
max_allowed_packet = 200M (in my.ini)

..and restarted all services, browser, computer and even cleared browser cache. I have used
the links to php.ini and my.ini from Wampserver menu.

For fun I tried to import it again and in this try phpmydamin announced that it is possible to import the same file again, then it will continue from where it stopped. This message turned up twice, and the db was expanded as expected, but on the third time I got the white page with the same error message, as I mentioned in my first post.

In my case, it's solved, I made the export in four parts, and then import. But it would be very convenient if it was possible to import large files via phpmyadmin.
And I still wonder where does this timelimit "300 seconds" come from?

I will try BigDump next time.

/Örjan

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: toumimi (84.6.111.---)
Date: September 14, 2009 11:32PM

You can add this line in phpmyadmin/config.inc.php file and change the value :
// maximum execution time in seconds (0 for no limit)
$cfg['ExecTimeLimit'] = 300;

Florian

WampServer Patch (Screenshots)
Topic EN : www.wampserver.com
Topic FR : www.wampserver.com

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: orjtor (---.mobileonline.telia.com)
Date: September 16, 2009 10:41PM

Thank you, it did work!

I tried with 1000 seconds and had to reload it twice to complete the import, but it did work.

I'll try 2000 seconds next time. I also made a new discovery, the "Extended inserts" have a significant impact on how quickly imports is performed, although the difference on the export file in my case is only 1.7 MB, between 13.5 MB and 15.2 MB.

Thanks for your support!
/Örjan

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: toumimi (84.6.111.---)
Date: September 16, 2009 11:36PM

You're welcome winking smiley

Florian

WampServer Patch (Screenshots)
Topic EN : www.wampserver.com
Topic FR : www.wampserver.com

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: yfastud (Moderator)
Date: September 17, 2009 01:41AM

@ orjtor

as mentioned above, changing 1 instance will not work properly since it has formula for it and all those instances related to each other and should change according to the rule from the formula winking smiley

Have fun,

FREE One A Day
FREE Photo
FREE Games
FREE Websites
FREE Portable GPS
FREE WAMP Guides

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: mrkamran82 (---.ericsson.net)
Date: April 03, 2011 12:08PM

Hi ALL,

I added "$cfg['ExecTimeLimit'] = 300;" into the "phpmyadmin/config.inc.php" and it worked fine for me.

I find that its not MYSQL problem as my query take very less time to respond with results. There is an issue with PHPMYADMIN(Especially PHP).

Why it is too slow in rendering the query result because i am using my local PC and its speed is quite ok to get result back in 300 Seconds. Because , i will use it in production and cannot wait for that long.

Is there any solution with Default setting of PHP rather than increasing ExecutionTime ????

Cheers!!!

Kamran S Khan




yfastud Wrote:
-------------------------------------------------------
> @ orjtor
>
> as mentioned above, changing 1 instance will not
> work properly since it has formula for it and all
> those instances related to each other and should
> change according to the rule from the formula winking smiley

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: rajbrijesh (117.196.252.---)
Date: February 26, 2012 09:20AM

Just go to line no 558 at
C:\wamp\apps\phpmyadmin3.4.9\libraries\config.default.php

change
$cfg['ExecTimeLimit'] = 300;
to
$cfg['ExecTimeLimit'] = 0;

smiling smiley

Options: ReplyQuote
Re: Maximum execution time of 300 seconds exceeded
Posted by: RiggsFolly (---.as13285.net)
Date: February 29, 2012 01:45AM

I would suggest giving up on phpMyAdmin and trying one of these ooption.

1. Use the command line to do you import.
something like this
mysql -p -u username database_name < file.sql
( database has to be created before you run this )

google 'mysql import database from command line'

2. Download MySQL Workbench its free, a windows based environment ( not php ) and easy to use.
you can even use it to manage remote mysql servers if the remote server can be configure to allow remote access.

Options: ReplyQuote


Sorry, only registered users may post in this forum.