Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Dragos (---.workpage.ro)
Date: February 13, 2023 11:38AM

I tried to upgrade the database, more precisely to go from mysql 8.0.31 to 8.0.32 by changing the version in the wampserver panel.
Immediately the task icon became red and remained so for 20-30 minutes. Seeing that nothing changed, I tried to restart all the services but nothing happened... everything was blocked. I had to stop everything from Taskmanager and after restarting the wampserver the icon became green but still with mysql version 8.0.31.
How should I proceed? Thank you very much.

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.3.1 (64bit)
php 8.2.2
mysql 8.0.31
phpmyadmin 5.2.1
apache 2.4.55.1
MariaDB 10.10.2

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Otomatic (Moderator)
Date: February 13, 2023 02:37PM

Right-Click -> Restart from zero

then change MySQL version Left-Click -> MySQL -> Version -> 8.0.32

See error message in mysql.log and in Windows Event Viewer

---------------------------------------------------------------
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Dragos (---.workpage.ro)
Date: February 13, 2023 03:13PM

No error in mysql.log but in Event viewer(after clear application events) have one error and one information:

Error:
Faulting application name: httpd.exe, version: 2.4.55.0, time stamp: 0x63da258a
Faulting module name: php_xdebug-3.2.0-8.2-vs16-x86_64.dll, version: 3.2.0.11, time stamp: 0x63923541
Exception code: 0xc0000005
Fault offset: 0x0000000000002191
Faulting process id: 0x21b0
Faulting application start time: 0x01d93fb43430dda8
Faulting application path: D:\wamp64\bin\apache\apache2.4.55.1\bin\httpd.exe
Faulting module path: D:\wamp64\bin\php\php8.2.2\zend_ext\php_xdebug-3.2.0-8.2-vs16-x86_64.dll
Report Id: 5cce0407-697e-4849-a36a-b1d5322899c4
Faulting package full name:
Faulting package-relative application ID:


Information:
Faulting application name: httpd.exe, version: 2.4.55.0, time stamp: 0x63da258a
Faulting module name: php_xdebug-3.2.0-8.2-vs16-x86_64.dll, version: 3.2.0.11, time stamp: 0x63923541
Exception code: 0xc0000005
Fault offset: 0x0000000000002191
Faulting process id: 0x21b0
Faulting application start time: 0x01d93fb43430dda8
Faulting application path: D:\wamp64\bin\apache\apache2.4.55.1\bin\httpd.exe
Faulting module path: D:\wamp64\bin\php\php8.2.2\zend_ext\php_xdebug-3.2.0-8.2-vs16-x86_64.dll
Report Id: 5cce0407-697e-4849-a36a-b1d5322899c4
Faulting package full name:
Faulting package-relative application ID:


If i try to check state of service show me confused smileytate of services:

The service 'wampapache64' is started
Start type : DEMAND_START
Service Session : LocalSystem

The service 'wampmysqld64' is started
Start type : DEMAND_START
Service Session : LocalSystem

The service 'wampmariadb64' is started
Start type : DEMAND_START
Service Session : LocalSystem

all services are started - it is OK

all services BINARY_PATH_NAME are OK
all services START_TYPE are OK

But icon are still red and after refresh come bacl to 8.0.31 version

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.3.1 (64bit)
php 8.2.2
mysql 8.0.31
phpmyadmin 5.2.1
apache 2.4.55.1
MariaDB 10.10.2



Edited 1 time(s). Last edit at 02/13/2023 03:22PM by Dragos.

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Otomatic (Moderator)
Date: February 13, 2023 03:42PM

Have you performed : Right-Click -> Restart from zero ?

Are you up to date in VC++ redistributables?

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

---------------------------------------------------------------
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Dragos (---.workpage.ro)
Date: February 13, 2023 04:42PM

After VC ++ check :All VC++ packages needed to Wampserver are installed correctly.
I have all packages for 86 and 64 bit. and repaired with administrator right each package.
I try to change version after: Restart, Reinstall services, Restart from zero with some results.



What happens if I delete the mysql 8.0.31 application? Does it work? Can I reinstall the database? smiling smiley smiling smiley

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.3.1 (64bit)
php 8.2.2
mysql 8.0.31
phpmyadmin 5.2.1
apache 2.4.55.1
MariaDB 10.10.2



Edited 1 time(s). Last edit at 02/13/2023 04:45PM by Dragos.

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Otomatic (Moderator)
Date: February 13, 2023 04:52PM

Hi,

This setup works flawlessly on my updated Windows 10 x64 system.

If this error problem "Faulting module name: php_xdebug-3.2.0-8.2-vs16-x86_64.dll" occurs again I can only see as a solution to disable xDebug :

Left-Click -> PHP -> PHP Extensions -> xdebug 3.2.0 to uncheck it

---------------------------------------------------------------
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Dragos (---.workpage.ro)
Date: February 13, 2023 05:51PM

I tried and it doesn't work... I also tried to change the dll and now the error doesn't appear anymore, but it still doesn't go to version 8.0.32 and stays stuck on the red color until I refresh it and then it returns to the old version... I also checked the integrity of the system files and no error appears... I will try to install wampserver again without version 8.0.31 tomorrow to see if it works...

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.3.1 (64bit)
php 8.2.2
mysql 8.0.31
phpmyadmin 5.2.1
apache 2.4.55.1
MariaDB 10.10.2

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Otomatic (Moderator)
Date: February 13, 2023 06:35PM

Hi,

> What happens if I delete the mysql 8.0.31 application? Does it work? Can I reinstall the database?

The only permanent and reliable way to reinstall a database is to export it as a SQL file with the functional MySQL version and then import the SQL file on the new version.

There is another way, a little more complicated, it is not to have its databases in the data folder of the MySQL (or MariaDcool smiley version used:

See item 09 of Wampserver 3 - Some explanations

---------------------------------------------------------------
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Dragos (---.workpage.ro)
Date: February 13, 2023 07:21PM

I have exported db like 127.0.0.1.sql

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.3.1 (64bit)
php 8.2.2
mysql 8.0.31
phpmyadmin 5.2.1
apache 2.4.55.1
MariaDB 10.10.2

Re: Upgrade Mysql from 8.0.31 to 8.0.32 in wamp 3.3.1 error
Posted by: Dragos (---.workpage.ro)
Date: February 14, 2023 09:14AM

Work fine...after install from 0....change mysql version without db in wamp

===========================
thank you,
Dragos
===========================
I use:
windows 10 x64 bit
wampserver 3.3.1 (64bit)
php 8.2.2
mysql 8.0.31
phpmyadmin 5.2.1
apache 2.4.55.1
MariaDB 10.10.2

Sorry, only registered users may post in this forum.