php.ini problem
Posted by: Roy (
Date: June 13, 2006 11:48PM

I just figured out a problem I was having that I believe is a wamp bug. Since I don't see a "submit bug" link, I'll post it here. After upgrading to the latest wamp, my short syntax PHP (e.g. <?=$var?>winking smiley stopped working. When I viewed the php.ini file using the wamp menu (system tray) it said "short_open_tag = On". I eventually figured out Config files in the wamp menu is pulling up php.ini from wamp\Apache but the "real one" is in wamp\Apache2. I confirmed the menu is getting the wrong file by renaming the one in Apache to php_old.ini and now the wamp menu says it can't find the ini file. Is there a way to get the wamp menu to point to php.ini in Apache2 or does a wamp developer need to fix that? And BTW, can I delete the Apache directory now that wamp uses Apache2?

Re: php.ini problem
Posted by: roms (
Date: June 14, 2006 09:07AM

I think you upgraded from a version previous then 1.6.0 which is not possible. Save your data (files and databases) uninstall and reinstall the latest version (upgrades are possible since 1.6.0 not before).

Now for your short_open_tags problem, they have been disactivated, you should use full open tags (<?php) since short_open_tags are not compatible with xhtml.


Re: php.ini problem
Posted by: Roy (
Date: June 14, 2006 09:05PM

You're right. I upgraded from 1.4 but according to the help file, "WAMP5 is now build to upgrade directly without losing your data (since WAMP 1.0)." Anyway, I uninstalled wamp and reinstalled it and the menu now points to the correct ini file. It also has some nice new options that weren't there when I upgraded. Thanks for the tip.

Now I need to figure out why phpMyAdmin won't run...

Sorry, only registered users may post in this forum.