Remove EOL packages from future full installers
Posted by: Tarek Hasan (103.176.18.---)
Date: November 24, 2022 07:10AM

PHP 5.6 was retired in 2018. And there's also 7.0,7.1,7.2,7.3 included in the installer. Default installer should not include EOL software packages. WAMP should not encourage the bad practice of using outdated and vulnerable software. Whoever wants to use them can easily add them later.

Removing EOL PHP versions would also remove requirement to include PhpMyAdmin 4.9. Thus reducing the total size of installation.

Also, instead of telling users to install multiple vc redist, just tell them to install this single package which install all vc redists for you. [github.com]
this will help with user annoyance and frustration.

Options: ReplyQuote
Re: Remove EOL packages from future full installers
Posted by: Otomatic (Moderator)
Date: November 24, 2022 01:51PM

Hi,

Wampserver 3.3.0 full install will include only:
- PHP 7.4.33, 8.0.26, 8.1.13, 8.2.0
- PhpMyAdmin 5.2.0
- Adminer 4.8.1
- PhpSysInfo 3.4.2
- MySQL 5.7.40 (or 8.0.31 for 64bit)
- MariaDB 32bit 10.5.13 or 10.6.5
- MariaDB 64bit 10.5.18 or 10.6.11 or 10.7.7 or 10.8.6 or 10.9.4 or 10.10.2

For the VC Redist install, I will see.

Thank.

------------------------------------------------------------------------------------------------------------
Wampserver 3.3.0 32 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.3.0 64 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Remove EOL packages from future full installers
Posted by: Tarek Hasan (103.176.18.---)
Date: November 24, 2022 02:23PM

Hi,
Thanks for your reply. If you start to suggest VC Redist AIO pack to users. For better install experience without errors, you can give them instructions in simple two line like this
1. Uninstall any previously installed VC Redist packages
2. Download and install latest version of VC Redist AIO Pack from here [github.com]

Options: ReplyQuote


Sorry, only registered users may post in this forum.