Wampserver.lib.php error
Posted by: iztokba (---.static.amis.net)
Date: October 06, 2022 03:06PM

Hello

I have problem with latest wampserver, Aestan Tray Menu
When i won to change the version of php or apache or just empt logs i get this errro in php logs

PHP Fatal error: Uncaught Error: Call to undefined function proc_open() in C:\wamp64\scripts\wampserver.lib.php:1209
Stack trace:
#0 C:\wamp64\scripts\wampserver.lib.php(507): proc_open_output()
#1 C:\wamp64\scripts\refreshVerifyFiles.php(265): retrieve_apache_define()
#2 C:\wamp64\scripts\refresh.php(50): require('...')
#3 {main}
thrown in C:\wamp64\scripts\wampserver.lib.php on line 1209

if anybody have idea what is wrong, please let me know

thanks

Options: ReplyQuote
Re: Wampserver.lib.php error
Posted by: Otomatic (Moderator)
Date: October 06, 2022 04:21PM

Hi,

proc_open() is an internal function of PHP since php 4.3.0 and is part of core PHP, so does not depend on any extension
See proc_open

I do not understand why there is this PHP Fatal error: Uncaught Error: Call to undefined function proc_open().

Maybe because the installation and/or the update of Wampserver have not been done "as administrator" or because you are not up to date in the VC++ redistributables.

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.3.0 32 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.3.0 64 bit - Apache 2.4.54.2 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wampserver.lib.php error
Posted by: iztokba (---.narocnik.mobitel.si)
Date: October 06, 2022 05:22PM

hello

i have all VC++ packages insateld
i reinstal last Wampserver and Aestan Tray Menu, but still have the same error.
What should i check?

thanks for help

Options: ReplyQuote
Re: Wampserver.lib.php error
Posted by: iztokba (---.narocnik.mobitel.si)
Date: October 06, 2022 05:44PM

i run wampmanager.ini repair and now is ok

Work like a charm

thanks

Options: ReplyQuote


Sorry, only registered users may post in this forum.