Phpmyadmin not compatible with php
Posted by: olasubomi2007 (
Date: September 21, 2022 09:30PM

Please, can anyone help me out with this issue on wampserver. The wampserver was working properly until I needed to download composer installer for a particular program download. Before, I could download or use the compser installer it requires php version 8.1.0 I was running on php version 7.4.26 so I needed to get my wampserver php version updated.
Now, since I added php version 8.1.0 to the wampserver, accessing both my project from the local host and database from the phpmyadmin has been an issue.
If I use lower version of php accessing my project would be giving an error message that the composer is requiring a php version 8.1.0 and if I use the php version 8.1.0 it would actually work in loading my project from the local host but accessing phpmyadmin would be a problem giving an error message phpmyadmin version 5.1.1 is not compatible with php 8.1.0 and giving deprecation notice error: .\vendor\twig\src\markup.php#40,35......
I don't really understand all these issues.
I would appreciate it if this question is being considered and responded to in good time.
Thanks for your patience.

Edited 1 time(s). Last edit at 09/22/2022 08:54AM by Otomatic.

Options: ReplyQuote
Re: Phpmyadmin not compatible with php
Posted by: Otomatic (Moderator)
Date: September 22, 2022 09:02AM


First, you don't post a message in a discussion that is more than twelve years old.

Secondly, you choose a title or subject related to the problem.

Third, the message is very clear: PhpMyAdmini 5.1.1 is not compatible with PHP 8.1.0.

So, you install a version of PhpMyAdmin compatible with PHP 8.1.0 => PhpMyAdmin 5.2.0.

This is very clearly indicated on :

Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons

Options: ReplyQuote

Sorry, only registered users may post in this forum.