Wamp Server 2.2 Intermittent connection issue
Posted by: homerj99 (---.nshealth.ca)
Date: September 16, 2022 04:26PM

Hi, I have installed Wamp 2.2 on my Windows server 2019 64 bit OS.
I have several pages hosted here that I moved from an old 2013 server, this is the reason why I kept Wamp 2.2 to avoid re writing in mysqli.
However, intermittently I cannot load localhost/phpmyadmin or load the hosted webpages from the LAN.
When there are page loading delays or timeouts and I check the port 80...it just hangs and shows no result.
To rectify the loading issues I have been restarting the Apache service and this causes the page(s) to load.

There is no Skype or IIS manager installed on this server.

Is it possibly the older version of Wamp causing this or something else? I have tried the cgi module disable etc.
Thanks

Options: ReplyQuote
Re: Wamp Server 2.2 Intermittent connection issue
Posted by: Otomatic (Moderator)
Date: September 16, 2022 07:18PM

Hi,

> Wampserver 2.2

Are you kidding? with apache 2.2.51, it's not supported since a long time!

You can install Wampserver 3.2.6 and use older versions of MySQL and PHP that support mysql.

See https://wampserver.aviatechno.net/

As for PhpMyAdmin access via the LAN, that's another problem.
See :
The need for Virtual Host
and
Wampserver 3 - Create or add a VirtualHost
and
MySQL users managment

To use older versions of MySQL and PHP, it is necessary to :
- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- If it is not already done, apply Update 3.2.9 to your version of Wampserver
Wampserver update 3.2.9

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.10 32 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.10 64 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp Server 2.2 Intermittent connection issue
Posted by: homerj99 (---.nshealth.ca)
Date: September 16, 2022 09:01PM

Thanks for the reply, yes I know, behind the times, I will update my wamp and try and install the mysql supported versions of mysql and php

Where/how can I find out which older versions of MySQL and PHP support mysql ?
Also, is there a "tutorial" on how to add these versions into WAMP?


Also regarding >> As for PhpMyAdmin access via the LAN, that's another problem.
That was faulty clarification on my end, I meant that when I am on the server and try and launch localhost/phpmyadmin it often doesnt load also...leading to the fact that it was an issue on the localhost server as well a webpages on the LAN.
Thank you again



Edited 2 time(s). Last edit at 09/16/2022 10:08PM by homerj99.

Options: ReplyQuote
Re: Wamp Server 2.2 Intermittent connection issue
Posted by: Otomatic (Moderator)
Date: September 17, 2022 08:53AM

Hi,

For example, just look at the PHP documentation for the mysql_connect statement:
mysql_connect
to see :
Warning
This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0.

So, the mysql extension still works, although deprecated, with PHP 5.6.40.

And, PHP 5.6.40 is part of Wampserver 3.2.6

Adding a PHP or MySQL version to Wampserver is easy : just launch the php or mysql addon executable "as administrator" and then change the PHP or MySQL version via the Wampmanager menus.
You can also change the PHP version only for one VirtualHost by switching it to FCGI mode via the "Add a VirtualHost" page.
See WAMPserver 3 - All you need to know

For FCGI mode, you must have done the Wampserver 3.2.9 update, so you must also have checked the VC++ redistributables.
- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- Apply Update 3.2.9 to your version of Wampserver
Wampserver update 3.2.9

Start by running your old sites under the proper versions of PHP and MySQL and only then we will look into accessing PhpMyAdmin via the LAN although I wonder why you need that.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.10 32 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.10 64 bit - Apache 2.4.54 - PHP 8.2.0…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.17/10.9.2
PhPMyadmin 5.2.0 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp Server 2.2 Intermittent connection issue
Posted by: homerj99 (---.nshealth.ca)
Date: September 17, 2022 09:29PM

Thank you thank you thank you, I can't thank you enough, greatly appreciate your help, solved my issue, again thank you

Options: ReplyQuote


Sorry, only registered users may post in this forum.