403 Forbidden PhpMyAdmin After 3.2.9 Update
Posted by: Euler13 (84.21.151.---)
Date: June 16, 2022 10:18AM

After updating to Wampserver 3.2.9 64-bit I am getting a 403 Forbidden error when trying to access PhpMyAdmin from localhost/phpmyadmin.

I upgraded to PhpMyAdmin 5.2.0 at the same time, but even reverting back to an older version: 5.1.3, did not fix the problem. I have no problem accessing the webserver, just this alias.

Any help would be appreciated.

FYI: I'm using PHP8.1.3 and Apache 2.4.51.

Options: ReplyQuote
Re: 403 Forbidden PhpMyAdmin After 3.2.9 Update
Posted by: Otomatic (Moderator)
Date: June 16, 2022 12:55PM

Hi,

It has nothing to do with the 3.2.9 update.

Whatever the version of Wampserver, PhpMyAdmin is always called in the same way and with the same alias.

From the Wampserver home page by :

'http://localhost/phpmyadmin4.9.10/'
or
'http://localhost/phpmyadmin5.2.0/'
or in some cases
'http://localhost/phpmyadmin/'

The alias is, depending of PhpMyAdmin version
Alias /phpmyadmin5.2.0 "${INSTALL_DIR}/apps/phpmyadmin5.2.0/"

<Directory "${INSTALL_DIR}/apps/phpmyadmin5.2.0/">
  Options +Indexes +FollowSymLinks +MultiViews
  AllowOverride all
  Require local
# To import big file you can increase values
  php_admin_value upload_max_filesize 128M
  php_admin_value post_max_size 128M
  php_admin_value max_execution_time 360
  php_admin_value max_input_time 360
</Directory>
Clear your browser cache and try with another browser.

PhpMyAdmin 5.2.0 launches very well via 'http://localhost/phpmyadmin5.2.0/' from Firefox, Chrome, Opera, Edge if they are not configured to accept only https.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: 403 Forbidden PhpMyAdmin After 3.2.9 Update
Posted by: Euler13 (84.21.151.---)
Date: June 16, 2022 01:11PM

Thank you for your reply.

I tried clearing caches and tried in different browsers, but I still got a 403.
When I click on the Wampserver icon and go to phpMyAdmin it tries to launch localhost/phpmyadmin.
I checked the alias: phpmyadmin.conf and it was pointing to the correct location: apps/phpmyadmin5.1.2.
So I typed localhost/phpmyadmin5.1.2 directly into the address bar and that worked.
I then re-installed phpmyadmin5.2.0 and selected "Add to existing version" rather than the replace option. After that, the Wampserver link now goes to localhost/phpmyadmin5.2.0 and it works!

I have no idea what broke, but I suspect it was going with the replace option during install (and then suppressing other versions).

Apart from installing Wamp Server 3.2.9 (going from 3.2.7) and phpMyAdmin 5.2.0 (from 5.1.2), I went from a system that had been updated many times before and worked perfectly to one that gave me a 403 error for phpMyAdmin. So if I can answer any more questions to help understand what may have caused this, and help others who might experience the same issue, then please ask.



Edited 2 time(s). Last edit at 06/16/2022 03:04PM by Euler13.

Options: ReplyQuote


Sorry, only registered users may post in this forum.