CLI and HTTP must be set to PHP 8.0
Posted by: Destron (---.49.149.141.231.pldt.net)
Date: June 11, 2022 04:35AM

I'm trying to install Akaunting 3.0 on my Wampserver.

Upon running the Akaunting site for installation, it tells me I need PHP version 8.0 for both HTTP and CLI.

I managed to set PHP from 7.4 to 8.0 and have adjusted CLI to 8.0 also. I still get the same message.

Where do you set the HTTP to use PHP 8.0?

Options: ReplyQuote
Re: CLI and HTTP must be set to PHP 8.0
Posted by: Otomatic (Moderator)
Date: June 11, 2022 09:44AM

Hi,

Left-Click -> PHP¨-> Show the use of PHP versions
For example:
-- Use of PHP versions

 PHP 5.6.40  used as CLI
 PHP 7.0.33  not used
 PHP 7.1.33  not used
 PHP 7.2.34  not used
 PHP 7.3.33  not used
 PHP 7.4.30  used as FCGI
  FCGI used by:
  Alias:       phpmyadmin4.9.10
  VirtualHost: mysqldumper
  VirtualHost: xn--mes-frres-et-ma-sur-vyb27t

 PHP 8.0.20  not used
 PHP 8.1.7   used as APACHE module

The PHP version defined as CLI is only used for Wampserver1 PHP scripts

The PHP version defined as APACHE module is the one used by HTTP
But you can use another PHP version for HTTP by using FCGI for your VirtualHost.
Then using a PHP version for an application depends only on the configuration of this application.
Of course, provided that the PHP version you want to use is installed in Wampserver.

You can use PHP 8.0.20 as an Apache module in HTTP mode and use the same version in CLI mode for your application, just use the file wamp64\bin\php\php8.0.20\php.exe

1 This term of CLI is confusing because it concerns only the internal functioning of Wampserver and in no case a CLI use by a WEB application or a CMS.
To avoid this confusion, the possibility to change the internal CLI version of Wampserver will be removed in a future version.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: CLI and HTTP must be set to PHP 8.0
Posted by: Destron (---.49.149.142.190.pldt.net)
Date: June 15, 2022 04:05AM

This is the current Wampserver localhoust configuration:

Server Configuration
Apache Version:
2.4.51 - Documentation Apache
Server Software:
Apache/2.4.51 (Win64) PHP/8.1.0 - Port defined for Apache: 80
PHP Version:
8.1.0 - Documentation PHP

And I still get the message:
Error: Ask your hosting provider to use PHP 7.3.0 or higher for both HTTP and CLI.

Options: ReplyQuote
Re: CLI and HTTP must be set to PHP 8.0
Posted by: Otomatic (Moderator)
Date: June 15, 2022 09:24AM

Hi,

> Ask your hosting provider to use PHP 7.3.0 or higher for both HTTP and CLI.

Wampserver is the master of the PHP version used in HTTP, i.e. as an Aapache module.
This is the PHP version displayed with the Left-Click.

Wampserver does not force a PHP version for CLI mode. The WEB application is free to use any PHP version as long as this version is installed in Wampserver.

Wampserver can also be used in FCGI (Fast CGI) mode via the Apache module fcgi_module, mode which is supported since Wampserver 3.2.8.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.54 - PHP 8.1.8…5.6.40 - MySQL 5.7.39/8.0.30 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.