wampserver 64 update
Posted by: ronford (---.bchsia.telus.net)
Date: April 06, 2022 10:51PM

A couple of months ago I downloaded and installed Wampserver 64 bit version 3.1.4 from the WampServer web site. I recently got a message from SourceForge that wampserver3_update_xdebug_3.1.4.exe was available.
My current xdebug is 3.1.1.
When I downloaded and tried to install the update, the following message was given:

"The current version of installed Wampserver is 3.2.6
The addon can only be done on version 3.2.8 or more
Install Wampserver 3.2.8 or more update after cancel the install."

I thought 3.1.4 was the latest version of wampserver. In any event, xdebug seems to be working OK except for a few minor annoyances. But, myphpadimin 5.1.1 couuld use an update because of the 'ignore all' error messages that popup with every action.

Is it possible to just update myphyadmin without upsetting anything else?
Thanks for you help.

Options: ReplyQuote
Re: wampserver 64 update
Posted by: Otomatic (Moderator)
Date: April 06, 2022 11:01PM

No

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver 64 update
Posted by: Otomatic (Moderator)
Date: April 07, 2022 09:45AM

Hi,

My previous answer was very terse!

> A couple of months ago I downloaded and installed Wampserver 64 bit version 3.1.4

A couple of month ago, Wampserver full install version was 3.2.6
2021-11-24 : Wampserver full install 3.2.6 - Wampserver Update 3.2.6
Acouple of month ago, Wampserver update version was 3.2.7 then 3.2.8
2021-12-16 : Wampserver Update 3.2.7
2022-03-10 : Wampserver Update 3.2.8

Perform the following operations in order:

- 1 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 2 - Apply Update 3.2.8 to your version of Wampserver
Wampserver update 3.2.8

- 3 - Apply update xDebug 3.1.4
Update xDebug 3.1.4 32 & 64 bit

- 4 - Install PhpMyAdmin 5.1.3
PhpMyAdmin 5.1.3 does not support PHP 5.5, 5.6 and 7.0.
Supported by PHP 7.1, 7.2, 7.3, 7.4, 8.0 and 8.1
This version can be added to an existing version, you will have the choice during the installation.
PhpMyAdmin 5.1.3

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver 64 update
Posted by: ronford (---.bchsia.telus.net)
Date: April 09, 2022 01:35AM

Thanks for the detailed instructions. However, I have not been able to download the check_vcedist.exe tool without getting an MD5 error. I've tried to locate another site other the [wampserver.aviatechno.net] without success and wonder if you had any suggestions.
Again, thanks.

Options: ReplyQuote
Re: wampserver 64 update
Posted by: maximus23 (---.dynamic.voo.be)
Date: April 09, 2022 01:55AM

Hi,

[wampserver.aviatechno.net] is the author's site and the program is signed with a numeric signature.

smiling smiley

Options: ReplyQuote
Re: wampserver 64 update
Posted by: ronford (---.bchsia.telus.net)
Date: April 09, 2022 06:57PM

My face is red. I managed to include an extra space at the end of the MD5 string. In summary, I managed to update VC++ packages, wampserver update, xDebug and PhyMyAdmin as per your instructions, and rebooted the computer.
After starting wampserver, when I run the wampserver manager, the following is displayed:
- wampserver 3.2.6
- phyadmin 5.1.1
- apache 2.4.51
- php 8.1.0
- mysql 5.7.36

Even though phyadmin 5.1.3 is in the wampserver64/apps folder, it is not being picked up. Is there a setting I need to change in a config or ini file? The is also a phpMyAdmin-5.1.3-englidh-new file in the same folder.
As aside the wampserver.conf file shows the update as 3.2.8.

Also, I would like to say that your website and instructions are superb - certainly one to the best I've ever come across.
Again, thanks for your time and help.

Options: ReplyQuote
Re: wampserver 64 update
Posted by: Otomatic (Moderator)
Date: April 10, 2022 11:24AM

Hi,

To start again on a good basis, we are going to make a "cleaning":

- Right-Click -> Tools -> Empty logs -> Empty all logs -> Y

- Exit Wampserver

Delete all phpmyadminx.y.z folders in wamp64\apps\

Delete all phpmyadminx.y.z.conf files in wamp64\alias\

Install PhpMyAdmin 5.1.3

If you need PhpMyAdmin for php version before 7.1, install PhpMyAdmin 4.9.10 with option to add to PhpMyAdmin version already installed.

Launch Wampserver.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wampserver 64 update
Posted by: ronford (---.bchsia.telus.net)
Date: April 10, 2022 07:34PM

Everything is working as it should!! Thank you so much, I really appreciate your help.

Options: ReplyQuote


Sorry, only registered users may post in this forum.