Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 17, 2022 05:02PM

I had Wampserver 5.2.6 with Apache 2.4.37, PHP 7.3.1, MySQL 5.7.24

I want to upgrade to PHP 7.4 and then 8.0, and have tried following the instructions in [stackoverflow.com], and downloading from [wampserver.aviatechno.net].

I have therefore run the following .exe (with several reboots):
vcredist_2022_x64, vcredist_2022_x86, wampserver3_x86_x64_update3.2.7, wampserver3_x64_addon_php7.4.27, wampserver3_x64_addon_php8.0.14

and a few others in case they are of interest later:
wampserver3_x64_addon_php8.1.1, wamp3_x86_x64_aetray3.2.4.2, wampserver3_phpsysinfo3.4.0, wampserver3_x64_addon_apache2.4.52, wampserver3_x64_addon_mysql8.0.27

After all this and another reboot, my wampserver starts OK, but it looks to me as though the versions available to me are only what I had before (eg PHP 5.6.40 to 7.3.1, Apache 2.4.37).

Looking a little closer it all seems OK as I see the folders for php 7.3.1 etc in wamp64/bin OK, and localhost says that Wampserver is at Version 3.2.7 - 64bit.

The one oddity is that when I run check_vcredist.exe it says that both Visual C++ 2015-2022 x86 - 14.30.30704 and Visual C++ 2015-2022 x64 - 14.30.30704 are **** NOT INSTALLED ****. The actual versions of vcredist_2022_x64 and vcredist_2022_x86 I have downloaded and installed are 30708, as is confirmed when I try to reinstall them. I have tried downloading again but get the same results.

Have I missed something to get the latest versions of PHP and Apache available to me?

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: Otomatic (Moderator)
Date: January 17, 2022 06:07PM

Hi,

> The one oddity is that when I run check_vcredist.exe it says that both Visual C++ 2015-2022 x86 - W14.30.30704

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.

- To correct your problem :
Right-Click -> Restart from zero

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 17, 2022 10:06PM

Thanks for the response. I have done this several times now - uninstalling the VCs, downloading the check_vcredist, VC 2015-2022 (VC17 x86) 14.30.30708, and c64 exes all at the same time - then running the installs and check.
Each time I am told that I need the 14.30.30704 versions and I can only install the 14.30.30708 versions.

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: Otomatic (Moderator)
Date: January 18, 2022 09:38AM

Hi,

Sorry, but there was probably a wrong file transfer.

Now the file check_vcredist.exe is the correct one, both on https://wampserver.aviatechno.net/files/tools/check_vcredist.exe and on SourceForge.

Right-click on the uploaded file, Properties, Details, the version should be 14.30.30708.0

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 18, 2022 12:09PM

Thanks. I managed to download that version of check_vcredist.exe (after clearing cache etc) and it shows that my VC setup is OK. That leaves the original problem that no PHP versions beyond my current 7.3.1 are showing as options, even though they are installed.
I have downloaded and re-installed the Wampserver update 3.2.7, but if I try to re-install PHP 7.4.27 64 bit x64, it just says that it is already installed.
One odd thing is that if I click to switch down to PHP 7.2.14 Wampserver restarts OK and localhost shows that it is using PHP 7.2.14. But in the tray icons, PHP 7.3.1 is still the one ticked. I can switch back OK to PHP 7.3.1, but still no later versions are showing.
Any suggestions?

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: Otomatic (Moderator)
Date: January 18, 2022 05:58PM

Hi,

> That leaves the original problem that no PHP versions beyond my current 7.3.1

Right-Click Wampmanager icon -> Restart from zero

You can see why by Right-Click -> Help -> Help Refresh - Restart from zero

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 20, 2022 12:58PM

Thanks. Maybe I missed a step? When I right-click I do not have the Restart from zero option.

On right-clicking all I have is About/Refresh/Language/Wamp Settings/Tools/Help/Exit.

(BTW I have tried clearing all logs as in a solution for someone else, but no improvement.)

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: Otomatic (Moderator)
Date: January 20, 2022 01:36PM

Hi,

> I do not have the Restart from zero option.
This option came with Wampserver 3.2.6 as you can see in the Changelog.
Right-Click -> About -> What's New
or
https://wampserver.aviatechno.net Changelog button.

As you have theoretically applied the 3.2.7 update you should have this option.

Did you run this update "As administrator"?
You can restart it without any problem.

What does restart from zero do?
- Stop all services
- Empty ALL log files in wamp(64)/logs/
- Empty the wamp(64)/tmp/ folder
- Quit Wampserver
- Restarts Wampserver

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 20, 2022 05:13PM

Thanks. I confirm that I did run the 3.2.7 update as administrator, and I have tried downloading and running it again.
I have also done all the restart from zero steps as you list individually.

The situation is still the same: no PHP version above 7.3.1 showing, no restart from zero option on right-clicking.

I have run the configuration report and it all looks normal except for the message
*** ERROR *** The PHP configuration loaded file is:
C:/wamp64/bin/php/php5.6.40/php.ini
should be for PHP CLI
c:/wamp64/bin/php/php7.3.1/php.ini

I have used the tool to change the PHP CLI version, and it seems to work but I still get the same sort of error when checking the ini files. Could this be causing the problem?

I presume this is as expected: the configuration report shows for the Compiler Visual C++ versions used:
PHP 5.6.40 Compiler => MSVC11 (Visual C++ 2012) - Architecture => x64
PHP 7.0.33 Compiler => MSVC14 (Visual C++ 2015) - Architecture => x64
PHP 7.1.26 Compiler => MSVC14 (Visual C++ 2015) - Architecture => x64
PHP 7.2.14 Compiler => MSVC15 (Visual C++ 2017) - Architecture => x64
PHP 7.3.1 Compiler => MSVC15 (Visual C++ 2017) - Architecture => x64
PHP 7.4.27 Compiler => Visual C++ 2017 - Architecture => x64
PHP 8.0.14 Compiler => Visual C++ 2019 - Architecture => x64
PHP 8.1.1 Compiler => Visual C++ 2019 - Architecture => x64

[I note that these last three are the ones not showing when I right-click]

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: Otomatic (Moderator)
Date: January 21, 2022 08:36AM

Hi,

In your anti-virus and/or anti-spyware and/or anti-buggy, put in exception :

The complete folder C:/wamp64/

The file C:\Windows\System32\drivers\etc\hosts

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 21, 2022 05:53PM

Thanks. I use BitDefender and have made the folder and file you list as exceptions for the anti-virus. Maybe not necessary but I rebooted and tried starting Wampserver and restarting from zero. There seems to be no improvement.

I have just noticed now that although localhost shows Wampserver to be at 3.2.7, the left-click menu says 3.2.0 - 64 bit - Services.

I do remember doing an upgrade a few years ago not as administrator and had to redo it as administrator. Might this have screwed things up for this upgrade?

I have tried re-installing the upgrade to 3.2.7 but with no improvement. Is there a way to undo upgrades and redo them fully?

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 21, 2022 09:39PM

Solved!

It was all caused by my having tracked down a PHP issue last year. I had kept several old php_error.log files and had renamed them php_errorOLD01.log etc. One of these was very large (133 MB ) so the Autoclean aspect of refresh.php was aborting. [PHP Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 136223677 bytes) in C:\wamp64\scripts\refresh.php on line 586.]

Now I have deleted those old php_errorOLDXX.log files everything works fine as far as I can tell.

Thanks for your help.

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: Otomatic (Moderator)
Date: January 22, 2022 09:15AM

Hi,

In one of my previous posts:

- Empty ALL log files in wamp(64)/logs/

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.9 32 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.9 64 bit - Apache 2.4.53 - PHP 8.1.5…5.6.40 - MySQL 5.7.38/8.0.29 - MariaDB 10.5.15/10.7.3
PhPMyadmin 5.1.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problem updating to PHP 7.4 etc
Posted by: PeterC66 (---.39.7.51.dyn.plus.net)
Date: January 22, 2022 02:14PM

Thanks. I did click on the tool option to Empty all log files but did not realise it needed to be all files in C:\wamp64\logs.

Thanks again for such an excellent system, and patient support.

Options: ReplyQuote


Sorry, only registered users may post in this forum.