RANSOMEWARE ISSUE
Posted by: rvanapeldoorn (---.adsl.xs4all.nl)
Date: November 13, 2021 02:41PM

Hi, i use WAMP 2.0 for my (old) website. Last week i have ransomware problems so my website was not working anymore.

Luckely i have a backup from my c:\wamp\ site with different websites

I installed a new clean windows, en restore de wamp backup on the same location.
in my hosts file i placed the names from my domainnames but every website is going on the default location.

On my (old) desktop i have a 'manual' to make more websites active, but the ransomeware encrypt these notes. And i don't understand what i doing wrong.

Can someone help me?

Options: ReplyQuote
Re: RANSOMEWARE ISSUE
Posted by: Otomatic (Moderator)
Date: November 13, 2021 03:17PM

Hi,

Wampserver 2.0 is a very old version which - if my memory serves me right - ran on Apache 2.2.6/2.2.11 and PHP 5.2.5/5.3.0.

We're at Apache 2.4.51 and PHP 8.0.12 (soon to be 8.1.0) and to find out why it's not working on your version, we'll have to dig up some old books and figure out what you mean by "to make more websites active".

Restoring the c:\wamp\ folder is not enough, you also need to recreate the wampapache and wampmysqld services.

To do this, you need to :
- Left-Click wampmanager icon -> Apache -> Service -> Create service
- Left-Click wampmanager icon -> MySQL -> Service -> Create service
- Left-Click wampmanager icon -> Start services

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: RANSOMEWARE ISSUE
Posted by: rvanapeldoorn (---.adsl.xs4all.nl)
Date: November 13, 2021 03:36PM

I understand that WAMP 2.0 is not the newest version. But the website is old but works fine for me. I'm not te developer from the website. When i used the newer versions of wamp my site won't work fine.

That is te reason i used this version.

What i mean over with more websites. I have my website, webmail and some other websites. On the same WAMP site.

Some of my websites is working, but not all. Some websites is going to the default location.

The create services (Service>Apache>install service)
and (mySQL>Install service)

I have done this, but the results are te same.

Options: ReplyQuote
Re: RANSOMEWARE ISSUE
Posted by: Otomatic (Moderator)
Date: November 13, 2021 04:59PM

Hi,

> Some of my websites is working, but not all. Some websites is going to the default location.

This requires a lot more information than "some" plus some other informations!

- Which version of Windows BEFORE the ransomware and which version reinstalled?
- Are you using Wampserver for local or external (Internet) access?
- Example of a site call that works, for example 'http://localhost/' or 'http://mysite/'.
- Same thing for which go to default location.
- What exactly do you mean by "default location"?

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.