cannot upgrade to mysql version 8.0.26
Posted by: philipzheng (
Date: September 16, 2021 01:30PM

I have tried to upgrade from mysql 5.7.31 to 8.0.26, but no matter what I do, the version is not showing up in WampManager tray icon > MySql > Version.

I have upgraded to wampserver 3.2.5, and installed the VC++ 2019 executables, and installed the MySql 8.0.26 add on from []. I have also tried following the steps below:
Exit Wampserver
Download MySQL version and extract to a folder, e.g. mysql-8.0.2-dmr-winx64
Copy the contents of the folder to a new mysql subdirectory, e.g. wamp64/bin/mysql/mysql8.0.2
Open a command windows (as an administrator) on wamp64/bin/mysql/mysql8.0.2/bin/
Type : mysqld.exe --initialize-insecure --- This will create the right data folder
Copy wampserver.conf from mysql5.7.14 to mysql8.0.2
Copy my.ini from mysql5.7.14 to mysql8.0.2
Edit mysql8.0.2/my.ini and replace all instances of mysql5.7.14 with mysql8.0.2 (then save)
Run WampServer64 as administrator

Still, WampManager only shows the MySql 5.7.31 version. Please enlighten me about what I am missing. Thanks in advance.

I am running Windows 10.0.19042.1237 x64.

Best Regards,


Edited 1 time(s). Last edit at 09/16/2021 01:31PM by philipzheng.

Options: ReplyQuote
Re: cannot upgrade to mysql version 8.0.26
Posted by: Otomatic (Moderator)
Date: September 16, 2021 02:56PM


- 1 - Right-Click -> Tools -> Empty logs -> Empty all log files -> Y

- 2 - Right-Click -> Refresh

- 3 - Right-Click -> Tools -> Create Wampserver configuration report

- 4 - Right-Click -> Tools -> Wampserver configuration report

- 5 - Put the content of the report here

Wampserver 3.3.0 32 bit - Apache - PHP 8.2.4…7.4.33 - MySQL 5.7.40 - MariaDB 10.5.13/10.6.5
Wampserver 3.3.0 64 bit - Apache - PHP 8.2.4…7.4.33 - MySQL 5.7.40/8.0.31 - MariaDB 10.5.17/10.10.2
PhPMyadmin 5.2.1 - MysqlDumper 1.24.5
on W10 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: cannot upgrade to mysql version 8.0.26
Posted by: philipzheng (
Date: September 18, 2021 04:57AM

Hello Sir,

Thank you for your help! I went through the steps you posted and it works now, it shows up the option to change to mysql 8.0.26. I don't know if it was because I pressed the refresh button or some other reason. The Wampmanager interface also seems to have changed slightly. It now reads Wampserver 3.2.5 at the top of the Wampmanager. I wonder if maybe it was stuck in the old version of Wampserver before but the refresh button unstuck it?

Best Regards,


Options: ReplyQuote

Sorry, only registered users may post in this forum.