OpenSSL 3.0
Posted by: WarriorGov9791 (---.hawaii.res.rr.com)
Date: September 10, 2021 03:46AM

I read that OpenSSL 3.0.0 has been released recently. Is it compatible with the current versions of WAMPServer (3.2.5), Apache (2.4.48a), and PHP (7.3.30, 7.4.23, 8.0.10)? If so, how do we get it to work with our current configurations? If not, what is the timeline for OpenSSL 3.0 to possibly be integrated with the next Apache update and is it worth it?

Thank you Oto and RiggsFolly for all that you do to keep WAMPServer going strong!

Aloha,
Ben

Windows 10 Pro 64-bit • WAMPServer 3.2.5 64-bit
Aestan Tray Menu 3.2.4.2 • Apache 2.4.51
PHP 5.6.40 (CLI) | 7.0.33 | 7.1.33 | 7.2.34 | 7.3.31 | 7.4.24 (active) | 8.0.11 • xDebug 3.1.1
phpMyAdmin 5.1.1 • MariaDB (Default DBMS) 10.5.8 • MySQL 5.7.35 | 8.0.26
AdMiner 4.8.1 • PHPSysInfo 3.3.4 • OpenSSL 1.1.1L
Latest VC++ packages installed and verified. (VC16 14.29.30135)

Options: ReplyQuote
Re: OpenSSL 3.0
Posted by: Otomatic (Moderator)
Date: September 10, 2021 09:11AM

Hi,

This has to be seen with Apache.

Wampserver uses Apache compilations directly from Apache Lounge.

The latest version (2.4.48a for Wampserver) includes openssl 1.1.1l.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.11…5.6.40 - MySQL 5.7.35 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.11…5.6.40 - MySQL 5.7.35/8.0.26 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: OpenSSL 3.0
Posted by: Otomatic (Moderator)
Date: September 11, 2021 05:11PM

Hi,

See Apache Lounge forum about OpenSSL 3 and Apache : [www.apachelounge.com]

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.11…5.6.40 - MySQL 5.7.35 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.11…5.6.40 - MySQL 5.7.35/8.0.26 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.