php8 addon
Posted by: tdawes33 (165.225.50.---)
Date: March 26, 2021 03:39AM

On Win10 I've run server 3.2.5 upgrade (from 3.2.4 install), and the php8.0.3 addon, but php8 is not appearing in my version menu.
Also updated to ATM-3.2.3.8

My redistributables are up to date (though check_vcredist.exe claims I'm missing VC_2019_REDIST_X86/X64 I've reinstalled them to no avail)

scripts/config.inc.php & scripts/wampserver.lib.php look correct (php8ts.dll and php_module are referenced respectively)


PHP7 continues to work fine, I just can't switch versions.

Thanks for any help

Options: ReplyQuote
Re: php8 addon
Posted by: RiggsFolly (Moderator)
Date: March 26, 2021 03:48AM

Did you apply the last update for the VC Runtimes VC Runtimes from here

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.4 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 2 time(s). Last edit at 03/26/2021 03:49AM by RiggsFolly.

Options: ReplyQuote
Re: php8 addon
Posted by: tdawes33 (165.225.50.---)
Date: March 26, 2021 04:26AM

yes

Options: ReplyQuote
Re: php8 addon
Posted by: RiggsFolly (Moderator)
Date: March 26, 2021 04:58AM

The redist checker offers you an option to output the result as a text file, can you do that and post it please

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.4 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: php8 addon
Posted by: tdawes33 (165.225.50.---)
Date: March 26, 2021 05:16AM

Sure. I had reinstalled these, and rebooted. Still reports as missing.

VC_2019_REDIST_X86 ID={e2803110-78b3-4664-a479-3611a381656a}
Visual C++ 2015-2019 x86 Additional Runtime - 14.28.29913
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2015-2019 (VC16 x86) 14.28.29913
----------------------------------------
VC_2019_REDIST_X64 ID={d992c12e-cab2-426f-bde3-fb8c53950b0d}
Visual C++ 2015-2019 x64 Additional Runtime - 14.28.29913
**** NOT INSTALLED ****
Installation file is on: [wampserver.aviatechno.net]
VC 2015-2019 (VC16 x64) 14.28.29913
----------------------------------------

Options: ReplyQuote
Re: php8 addon
Posted by: Otomatic (Moderator)
Date: March 26, 2021 10:21AM

Hi,

Use latest version of check_vcredist.exe

Try :
- Right-Click -> Tools -> Empty logs -> Empty all log files Y
- Right-Click -> Refresh

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.5 32 bit - Apache 2.4.46d - PHP 8.0.3…5.6.40 - MySQL 5.7.33 - MariaDB 10.5.9
Wampserver 3.2.5 64 bit - Apache 2.4.46d - PHP 8.0.3…5.6.40 - MySQL 5.7.33/8.0.23 - MariaDB 10.5.9
PhPMyadmin 5.0.4 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: php8 addon
Posted by: tdawes33 (165.225.50.---)
Date: March 26, 2021 05:36PM

Reports "All VC++ packages ... installed correctly" now.

Still, no Version 8 option in my php menu though

Options: ReplyQuote
Re: php8 addon
Posted by: tdawes33 (165.225.50.---)
Date: March 26, 2021 05:41PM

Woah.
I had refreshed multiple times with no effect, but, emptying the logs and refreshing worked.

Thanks?!

Options: ReplyQuote


Sorry, only registered users may post in this forum.