wrong apache used
Posted by: martin__ (---.pitcom.net)
Date: December 22, 2020 03:45PM

Hello!

I have two installatioins of wamp: C:/wamp (x86, v3.2.3) and C:/wamp64 (64bit, v3.2.4).
When I try to start the 64-Bit-version with php8 the following error occures:

>>> AH00526: Syntax error on line 53 of C:/wamp/bin/apache/apache2.4.33/conf/extra/httpd-ssl.conf:

(Check state of services)

Why is it seemingly starting the wrong apache/reading the wrong config? I found no reference to it anywhere in the wamp64 folder.

Thanks!

Options: ReplyQuote
Re: wrong apache used
Posted by: RiggsFolly (Moderator)
Date: December 22, 2020 03:48PM

Hi

Did you check which wampmanager you were using to do the start? To start the 64bit version of WAMP you use the wampmanager.exe inthe wamp64 folder etc.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: wrong apache used
Posted by: martin__ (---.pitcom.net)
Date: December 22, 2020 03:56PM

thanks for the fast reply.
yes, it is the correct wampmanager.exe (3.2.4). also the correct apache-version (2.4.46) shows up in the menu.



Edited 1 time(s). Last edit at 12/22/2020 04:06PM by martin__.

Options: ReplyQuote
Re: wrong apache used
Posted by: RiggsFolly (Moderator)
Date: December 22, 2020 04:18PM

Ok

Question:
When you say
Quote

When I try to start the 64-Bit-version with php8 the following error occures:

Do you mean you have PHP8 active within that Apache

OR

Do you mean that you have changed the version of PHP that is used by WAMPServer to run itself?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.5 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.23>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 12/22/2020 04:46PM by RiggsFolly.

Options: ReplyQuote
Re: wrong apache used
Posted by: Otomatic (Moderator)
Date: December 22, 2020 04:56PM

Hi,

Take me out of a doubt!
Before launching Wampserver 64bit, you leave Wampserver 32bit well?
Because the error mentions C:/wamp/bin/apache/ and not C:/wamp64/bin/apache/.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wrong apache used
Posted by: martin__ (---.dip0.t-ipconnect.de)
Date: December 22, 2020 06:50PM

Quote

Do you mean you have PHP8 active within that Apache

OR

Do you mean that you have changed the version of
PHP that is used by WAMPServer to run itself?


I am not shure, if I quite got your question.
When I start wamp64 with php8 selected in the menu, the previously mentioned error occures (orange icon).
When I change to php7.4 via menu apache starts perfectly well (green icon). I change back to php8 => error.
I guess it is running the x86 apache2.4.33, that is able to run with php7.4 but not 8? That is what the error message suggests, I think (C:/wamp/...). But I don't know why that is.



Edited 2 time(s). Last edit at 12/22/2020 06:56PM by martin__.

Options: ReplyQuote
Re: wrong apache used
Posted by: martin__ (---.dip0.t-ipconnect.de)
Date: December 22, 2020 06:53PM

Otomatic Wrote:
-------------------------------------------------------
> Hi,
>
> Take me out of a doubt!
> Before launching Wampserver 64bit, you leave
> Wampserver 32bit well?
> Because the error mentions C:/wamp/bin/apache/ and
> not C:/wamp64/bin/apache/.

yes. I even restarted windows, and freshly executed C:/wamp64/wampmanager.exe - same error

Options: ReplyQuote
Re: wrong apache used
Posted by: Otomatic (Moderator)
Date: December 22, 2020 07:08PM

Hi,

When the problem occurs, could you post here the complete results of :
- Right-Click -> Tools -> Check state of services

It would also be advisable to check :
- That all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: wrong apache used
Posted by: martin__ (---.pitcom.net)
Date: December 23, 2020 09:12AM

I installed the VC++ packages and it worked! Thank you Otomatic and RiggsFolly!

For sake of completeness, here is the full error-output:

State of services:

The service 'wampapache64' is NOT started
EXIT error code:1066
Help message for error code 1066 isgrinning smileyer Dienst hat einen dienstspezifischen Fehlercode zurückgegeben.
>>> Invalid command 'SSLCipherSuite', perhaps misspelled or defined by a module not included in the server configuration .
>>> AH00526: Syntax error on line 53 of C:/wamp/bin/apache/apache2.4.33/conf/extra/httpd-ssl.conf: .

The service 'wampmysqld64' is started
Service Session : LocalSystem

The service 'wampmariadb64' is started
Service Session : LocalSystem

WampServer (Apache, PHP and MySQL) will not function properly if any service
'wampapache64'
'wampmysqld64'
'wampmariadb64'
is not started.

all services BINARY_PATH_NAME are OK

--- Do you want to copy the results into Clipboard?
--- Press the Y key to confirm - Press ENTER to continue...

Options: ReplyQuote
Re: wrong apache used
Posted by: Otomatic (Moderator)
Date: December 23, 2020 12:45PM

Hi,

>>> Invalid command 'SSLCipherSuite', perhaps misspelled or defined by a module not included in the server configuration .
>>> AH00526: Syntax error on line 53 of C:/wamp/bin/apache/apache2.4.33/conf/extra/httpd-ssl.conf: .

The service status test checks whether the service is started via the :
sc query servicename | FINDSTR "STOPPED RUNNING"'
If a service is not started, we will look for the error code with the command :
sc queryex servicename | FINDSTR "WIN32_EXIT_CODE"'
and then the message relating to this error by the command:
net helpmsg errorcode

but the messages relating to a non-start of a service are not explicit on the cause of the non-start, that's why, for the Apache service, we will look for the last two entries of the event viewer by a command a little boring:
wevtutil qe Application /c:2 /rd:true /f:text /q:\"*[System[Provider[@Name='Apache Service'] and (Level=2)]]\"
and, these last two events are displayed.
But, even if these events are related to the Apache Service, we can't be sure that they are related to the last request to start the service.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.6 32 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.12/10.6.4
Wampserver 3.2.6 64 bit - Apache 2.4.51 - PHP 8.0.12…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.12/10.6.4
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.