Problems Installing Nuke Evolution CMS
Posted by: EmeraldDragon (---.res.spectrum.com)
Date: December 08, 2020 06:49PM

Hi,

I have installed wamp and tried to setup Nuke Evolution CMS. It will let me go through the process and finished with the installs, but display errors. I have tried both version of wamp (32bits and 64bits), and the results are the same.

It doesn't matters if I use Virtual Host or not.

Using the other webserver, I don't have this problems. So, I don't know if it's specific to WAMP or not. Or if I have it configured wrong some how.

Below is what I gets when I tried to installed, but it doesn't stop the installation:

-------------

( ! ) Notice: Undefined variable: failed in C:\Software\wamp\www\evolution\install\functions.php on line 172
Call Stack
#
Time
Memory
Function
Location
1 0.0006 442472 {main}( ) ...\install.php:0
2 0.0027 647704 chmod_files( ) ...\install.php:245



Edited 1 time(s). Last edit at 12/08/2020 06:50PM by EmeraldDragon.

Options: ReplyQuote
Re: Problems Installing Nuke Evolution CMS
Posted by: Otomatic (Moderator)
Date: December 08, 2020 07:13PM

Hi,

> Notice: Undefined variable: failed in C:\Software\wamp\www\evolution\install\functions.php on line 172
It's simple, there is an error in the installation script. The script wants to use the variable $failed but it has never been defined.
It has absolutely nothing to do with Wampserver. It is an error in the Nuke Evolution installation script.
Did you check the prerequisites for Nuke Evolution, i.e. supported PHP versions, necessary extensions, etc.?

It's at Nuke Evolution that you have to go ask your question, Wampserver is a server that is not necessarily configured like others where it works. So it's up to you to make sure that the server is compatible with Nuke Evolution.
It's easy to understand that a server, whatever it is, can't be configured for hundreds of CMS and thousands of WEB applications.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.4 32 bit - Apache 2.4.46c - PHP 8.0.2…5.6.40 - MySQL 5.7.33 - MariaDB 10.5.9
Wampserver 3.2.4 64 bit - Apache 2.4.46c - PHP 8.0.2…5.6.40 - MySQL 5.7.33/8.0.23 - MariaDB 10.5.9
PhPMyadmin 5.0.4 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Problems Installing Nuke Evolution CMS
Posted by: RiggsFolly (Moderator)
Date: December 08, 2020 07:23PM

Hi,

Its quite probable that the error has always been there, but as wampserver is a development server and configured to show errors so they can be fixed, you are seeing them. Whereas your other server may be configured as a live server and therefore errors only go to the error log and not to the screen.

Have a look at the servers error log, just to check

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.4 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Problems Installing Nuke Evolution CMS
Posted by: EmeraldDragon (---.res.spectrum.com)
Date: December 08, 2020 10:02PM

OK! Thanks.. Now I understand.

Options: ReplyQuote


Sorry, only registered users may post in this forum.