Unable to load extensions with Wamp 3.2.3
Posted by: mallen (---.res.bhn.net)
Date: November 30, 2020 05:20PM

After I updated my Wamp Server (3.2.3) and PHP 7.7.12 I cannot update plugins on my Wordpress locally and get this message: “Update failed: Download failed. No working transports found”.

I have curl and openssl extensions on. I checked the logs and it says Unable to load dynamic library ‘curl’ (tried: c:/wamp64/bin/php/php7.4.12/ext/curl

Unable to load dynamic library ‘openssl’ (tried c:/wamp64/bin/php/php7.4.12/ext/openssl

When I switch back to PHP 7.0.10 the updates will work and extensions will load. But I need 7.4.12 for my phpmyadmin and website to work.

Options: ReplyQuote
Re: Unable to load extensions with Wamp 3.2.3
Posted by: Otomatic (Moderator)
Date: December 01, 2020 03:21PM

Hi,

WordPress plugins and the automatic update procedure are not compatible with PHP 7.4.12.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.4 32 bit - Apache 2.4.46b - PHP 8.0.1…5.6.40 - MySQL 5.7.33 - MariaDB 10.5.8
Wampserver 3.2.4 64 bit - Apache 2.4.46b - PHP 8.0.1…5.6.40 - MySQL 5.7.33/8.0.23 - MariaDB 10.5.8
PhPMyadmin 5.0.4 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Unable to load extensions with Wamp 3.2.3
Posted by: mallen (---.res.bhn.net)
Date: December 03, 2020 05:10PM

Thanks. I am not trying the automatic update. Do I need to downgrade to 7.3 or which version will work? I need 7.1 to use PhpMyadmin

Options: ReplyQuote
Re: Unable to load extensions with Wamp 3.2.3
Posted by: Otomatic (Moderator)
Date: December 03, 2020 06:29PM

Hi,

> Do I need to downgrade to 7.3 or which version will work? I
Only you, from the WordPress plugins you have installed, can know which versions of PHP they are compatible with.

You say it works with PHP 7.0.10, so try PHP 7.1.33, then 7.2.34, then 7.3.25.
It only takes a few minutes to download the PHP addons and install them.
You can also check with the plugin vendors to find out which versions of PHP they are compatible with.

As for PhpMyAdmin, version 4.9.7 supports PHP 5.5, 5.6 and 7.0.

All addons are on https://wampserver.aviatechno.net/

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.4 32 bit - Apache 2.4.46b - PHP 8.0.1…5.6.40 - MySQL 5.7.33 - MariaDB 10.5.8
Wampserver 3.2.4 64 bit - Apache 2.4.46b - PHP 8.0.1…5.6.40 - MySQL 5.7.33/8.0.23 - MariaDB 10.5.8
PhPMyadmin 5.0.4 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Unable to load extensions with Wamp 3.2.3
Posted by: mallen (---.res.bhn.net)
Date: January 18, 2021 08:29PM

Otomatic Wrote:
-------------------------------------------------------
> Hi,
>
> WordPress plugins and the automatic update
> procedure are not compatible with PHP 7.4.12.

Correct. When I run them to update they Update failed: Download failed. No working transports found. If I switch back to PHP 7.0.10 they will update.

Options: ReplyQuote


Sorry, only registered users may post in this forum.