Pages: Previous12
Current Page: 2 of 2
Re: Public Access to WAMP 3.2.3
Posted by: Claudius (---.bardstown.com)
Date: August 17, 2020 06:14PM

I'm really struggling with this one.

You used a phrase, "installed into localhost" that I misinterpreted, didn't completely understand.

I went back and read the installation instructions again a couple times then I installed WAMP64 and I installed the, "redrubberball" file folder under d:/wamp64/www." I worked for the Japanese in the past and have managed a project that was implemented by British Aerospace. The guys from BAe used to tell me that we were a people divided by a common language. So I decided that you were saying something that I was not understanding clearly.

Then I went to, "localhost" from the WAMP icon in the system tray and set up the virtualhost and the Myphpadmin database user and database.

Then, I copied the extracted elgg website from downloads to d:/wamp64/www/redrubberball.

Then I started up the website installation page from the "redrubberball" hyperlink on the, "localhost" page opened from the WAMP icon in the system tray. The served webpage was distorted but I was able to finish the installation.

I have discovered that from the server machine, if I pull up the webpage landing page on Internet Explorer instead of MS Edge that I get the page undistorted. I still get the distorted landing page using IE from another computer on the internal network. And then so, I know that the distortion problem is internal to Edge.

Please see the included below, the, "hpptd-vhosts.conf" file. Please tell me if you see an edit that I need to make in order to get access from the public internet.

Thank you for your time even if it did take this long for me to understand. I'm slow like that a lot of times.

**************************************************************

# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName connections.dyndns-home.com
# ServerName redrubberball
DocumentRoot "d:/wamp64/www/redrubberball"
<Directory "d:/wamp64/www/redrubberball/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
# Require local
Require all granted
</Directory>
</VirtualHost>

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: Claudius (---.bardstown.com)
Date: August 17, 2020 09:23PM

OK, I have public http connectivity established. Going to focus now on ssl then we get this show on the road. You're welcome to an account if you want.

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: Claudius (---.bardstown.com)
Date: August 18, 2020 02:51AM

And this I resume is what httpd-vhosts.conf should look like, right?

# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
# Require all granted
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName connections.dyndns-home.com
# ServerName redrubberball
DocumentRoot "d:/wamp64/www/redrubberball"
<Directory "d:/wamp64/www/redrubberball/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
# Require local
Require all granted
</Directory>
</VirtualHost>

****************************************************************

Now...

I set up SSL according to directions and wampserver starts up the way it's supposed to but I can't connect by https. looking on another website I found this command line command:

"c:/wamp64/bin/apache/apache2.4.41/bin/httpd -t"

Some kind of debugger I guess. It tells me that I have a syntax error on line 36 of httpd-ssl.conf which I take as this line:

#
# When we also provide SSL we have to listen to the
# standard HTTP port (see above) and to the HTTPS port
#
#Listen 443

##
## SSL Global Context
##
## All SSL configuration in this context applies both to
## the main server and all SSL-enabled virtual hosts.
##

"Listen 443" which I commented out.

So what do you think I did wrong with this SSL set up?



Edited 1 time(s). Last edit at 08/18/2020 02:51AM by Claudius.

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: Otomatic (Moderator)
Date: August 18, 2020 09:51AM

Hi,

IMHO, it should be:

Listen 0.0.0.0:443 https
Listen [::0]:443 https

Listen is now a required directive. If it is not in the config file, the server will fail to start.
See [httpd.apache.org]

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: Claudius (---.bardstown.com)
Date: August 20, 2020 03:48PM

I'm having a bad time.

I'm trying to re-establish public access to my website after I broke WAMPserver3.2.3. Why doesn't this work?

# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName connections.dyndns-home.com
DocumentRoot "${INSTALL_DIR}/www/redrubberball"
<Directory "${INSTALL_DIR}/www/redrubberball/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require all granted
</Directory>
</VirtualHost>



Edited 1 time(s). Last edit at 08/21/2020 12:50AM by RiggsFolly.

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: RiggsFolly (Moderator)
Date: August 21, 2020 01:05AM

Nothing, I just got in to the site

Its got the `You do not have permissions to view the page you are trying to access` on a buttet point at the top of the page again

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: RiggsFolly (Moderator)
Date: August 21, 2020 01:23AM

If you look at the browsers debugger (F12)

Loading failed for the <script> with source “[localhost]”. register:61:1
Loading failed for the <script> with source “[localhost]”. register:61:1
Loading failed for the <script> with source “[localhost]”. register:61:1
Loading failed for the <script> with source “[localhost]”. register:61:1
Loading failed for the <script> with source “[localhost]”.

You will see that there are references to `localhost` (Badly Installed Probably)

When my browser attempts to load those scripts it looks at `localhost` which to MY BROWSER means MY PC. of course it does not find anything like that.


Again, the process it

1. Makes sure WAMPServer is working (just after installing it)
2. Create a Virtual Host.
3. copy the site into the VH folder
3. run the site Install from connections.dyndns-home.com/install (or how ever this site gets installed)

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 2 time(s). Last edit at 08/21/2020 11:30AM by RiggsFolly.

Options: ReplyQuote
Re: Public Access to WAMP 3.2.3
Posted by: Claudius (---.bardstown.com)
Date: August 21, 2020 07:33PM

Here is the current iteration of httpd-vhosts.conf. I get an error saying that I don't have permission to access the page.

# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName connections.dyndns-home.com
# ServerName redrubberball
DocumentRoot "d:/wamp64/www/redrubberball"
<Directory "d:/wamp64/www/redrubberball/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride all
Require all granted
</Directory>
</VirtualHost>

And I'll tell you something odd about the elgg website that I have discovered. When I navigate to the login page on a browser, I get the permission error problem. However, if I navigate to the "register" page or to the "forgot password page" and then use the "home" button to return to the login page and I can log into the website without the access permission error. What do you think about that?



Edited 1 time(s). Last edit at 08/21/2020 10:27PM by Claudius.

Options: ReplyQuote
Pages: Previous12
Current Page: 2 of 2


Sorry, only registered users may post in this forum.