upgrade from 3.1.7 to 3.2.0
Posted by: jaya (---.telstraclear.net)
Date: July 22, 2020 05:47AM

Hi There,

If I download the 3.2.0 installer and install on same folder will upgrade it without loosing any existing data/projects?

Thanks
Jaya

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: Otomatic (Moderator)
Date: July 22, 2020 09:53AM

Hi,

To update anything, it is necessary to run an update, not a full installer.

As indicated here https://wampserver.aviatechno.net/ in the Updates section.

Wampserver update 3.2.2
Updates only "Wampmanager", does not add any Apache PHP, MySQL or MariaDB versions. It is a cumulative update. It is not necessary to apply the old updates 3.0.1 to 3.2.1 before applying 3.2.2. There will be no changes to your Apache, PHP, MySQL, MariaDB settings and versions used; your local sites and databases will not be affected. This update is necessary to install the latest Apache, PHP, MySQL or MariaDB addons.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: jaya (---.telstraclear.net)
Date: July 27, 2020 12:23AM

Hi There,

I have updated wamp to 3.2.2 as it was required for Mysql8, then I installed the addon for Mysql 8.0.21. When I tried changing the version first it gave me VCRUNTIME140_1.DLL not found. Downloaded the dll and solved that error but wamp is just stopped working. Trying changing Mysql version back to 5.7.14 but throwing error "Could not execute menu item (internal error)"[Exception] could not perform built-in-action: No service has been opened yet!".

I am using Windows 10 64 bit.

Thanks J



Edited 1 time(s). Last edit at 07/27/2020 12:25AM by jaya.

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: Otomatic (Moderator)
Date: July 27, 2020 08:58AM

Hi,

> Downloaded the dll
NO, NO, NO and NO again !
A dll file must be installed for it to be registered by the system.
Delete the dll file you copied and then :

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: jaya (---.telstraclear.net)
Date: July 27, 2020 11:37PM

Hi,

Installed latest VC++ packages and running check_vcredist.exe showing message "All VC++ packages needed to Wampserver are installed correctly". Still not working and showing message "Could not execute menu item (internal error)"[Exception] could not perform built-in-action: No service has been opened yet!" when trying to change mysql version back to 5.7. Also realized a message on the bottom of the menus "No Default DBMS".

Please help me to solve the issue, I really love this tool and totally stuck for my local development.

Thanks
Jaya

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: jaya (---.telstraclear.net)
Date: July 28, 2020 01:57AM

Somehow I changed the mysql version to 5.7 and it turned orange now as apache service is running but not mysql.
When I tested for port 3306 it returns:
Port 3306 is not found associated with TCP protocol

C:\wamp64\www>php testmysql.php

Warning: mysqli::__construct(): (HY000/2002): No connection could be made because the target machine actively refused it.
in C:\wamp64\www\testmysql.php on line 11
Connect Error (2002) No connection could be made because the target machine actively refused it.

How I can identify the exact issue?

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: Otomatic (Moderator)
Date: July 28, 2020 09:50AM

Hi,

Result of Right-Click -> Tools -> Check state of service

--- The Wampmanager icon in the taskbar MUST be GREEN.
--- If the icon is not green, there is no point expecting everything to work as it means that one of the Apache/MySQL/MariaDB services has not started.

You can try :
Right-Click -> Tools -> Miscellaneous -> Reinstall all services

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: RiggsFolly (Moderator)
Date: July 28, 2020 12:11PM

Hi,

First thing to do ALWAY whenever you get issues is CHECK THE LOGS.

Look in wamp64\logs

If that does not make the issue obvious also cehk the Windows Event Viewer for messages from Apache or MYSQL or mariaDB

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 07/29/2020 03:51AM by RiggsFolly.

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: TheShadow (5.21.237.---)
Date: July 28, 2020 06:32PM

Hello there,

it's a newly bug ! Browse C:\wamp64\wampmanager.conf and modify the phpVersion to match the version which is shown in menu and you will get it back working

Good luck

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: Otomatic (Moderator)
Date: July 28, 2020 07:38PM

Hi,

>it's a newly bug !
Please explain, with examples, why this is a bug.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.3 32 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31 - MariaDB 10.5.5
Wampserver 3.2.3 64 bit - Apache 2.4.46 - PHP 7.4.9…5.6.40 - MySQL 5.7.31/8.0.21 - MariaDB 10.5.5
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: upgrade from 3.1.7 to 3.2.0
Posted by: jaya (---.vocus.co.nz)
Date: July 28, 2020 11:40PM

Thanks for help, There wasn't anything helpful in mysql logs other than following warning:

2020-07-28T20:35:05.761278Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.

Tried multiple things and I feel that "Install Service" option under MYSQL worked. Wampserver is back green now with Mysql 5.7.14 but Mysql 8.0.21 is still showing orange.

Options: ReplyQuote


Sorry, only registered users may post in this forum.