These are your folders in e:/wamp64/www To use them as an http link, you must declare them as VirtualHost
Posted by: toad78 (206.169.162.---)
Date: June 26, 2020 06:31PM

I just recently updated to WampServer 3.2.0. Overall, it's fully functional. However, after I updated, I lost all of my site links under "Your Projects". The projects are listed there but they are no longer linked. I'd appreciate some documentation or a way to recover the links to the Projects.

Thank you. smiling smiley

Options: ReplyQuote
Re: These are your folders in e:/wamp64/www To use them as an http link, you must declare them as VirtualHost
Posted by: Otomatic (Moderator)
Date: June 26, 2020 07:08PM

Hi,

For local sites, you must use VirtualHost, as with all hosting providers.
See: The need for Virtual Host
and: Wampserver 3 - Create or add a VirtualHost

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.2 32 bit - Apache 2.4.43 - PHP 7.4.7/7.3.19/..../5.6.40 - MySQL 5.7.30 - MariaDB 10.4.12
Wampserver 3.2.2 64 bit - Apache 2.4.43 - PHP 7.4.7/7.3.19/..../5.6.40 - MySQL 5.7.30/8.0.20 - MariaDB 10.4.12
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: These are your folders in e:/wamp64/www To use them as an http link, you must declare them as VirtualHost
Posted by: toad78 (206.169.162.---)
Date: June 26, 2020 11:44PM

I already have a 'VirtualHost', which has never changed, and I've updated WampServer many times. All of my sites are under localhost/www/. So why would the links just 'disappear' and yet leave the names of the Projects under the 'Your Projects' column? I don't have any problems accessing any of the sites by typing it in in teh URL bar. It's just that shortly after I updated WampServer, the sites under "Your Projects" are no longer clickable.

Options: ReplyQuote
Re: These are your folders in e:/wamp64/www To use them as an http link, you must declare them as VirtualHost
Posted by: toad78 (206.169.162.---)
Date: June 26, 2020 11:47PM

Just to add, I did add a VirtualHost to one of the sites I have listed. While after the creation it did create it and it did work fine, it seems WampServer is runnig very slow to access the site (and all of the others). Any reason why it runs slow?

Options: ReplyQuote
Re: These are your folders in e:/wamp64/www To use them as an http link, you must declare them as VirtualHost
Posted by: Otomatic (Moderator)
Date: June 27, 2020 11:38AM

Hi,

> the sites under "Your Projects" are no longer clickable.
And this is quite "normal" since it was not about sites, but only about folders; it is only the correction of an error.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.2 32 bit - Apache 2.4.43 - PHP 7.4.7/7.3.19/..../5.6.40 - MySQL 5.7.30 - MariaDB 10.4.12
Wampserver 3.2.2 64 bit - Apache 2.4.43 - PHP 7.4.7/7.3.19/..../5.6.40 - MySQL 5.7.30/8.0.20 - MariaDB 10.4.12
PhPMyadmin 5.0.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: These are your folders in e:/wamp64/www To use them as an http link, you must declare them as VirtualHost
Posted by: toad78 (206.169.162.---)
Date: June 27, 2020 06:18PM

Understood. Thank you for the clarification, Otomatic, and for your help. Everything seems to be functioning fine, then.

Options: ReplyQuote


Sorry, only registered users may post in this forum.