mod_deflate won't let Apache to run
Posted by: Serpher (
Date: May 14, 2020 11:56AM

I'm using Apache 2.4.37 x64 and when I enable mod_deflate it just won't go back up. I have mod_filter enabled so that's not it. Event Viewer and apache logs don't say anything. I can't find solution to this problem sad smiley

Turning off mod_filter makes icon green but I get error 500.

Edited 1 time(s). Last edit at 05/14/2020 12:13PM by Serpher.

Options: ReplyQuote
Re: mod_deflate won't let Apache to run
Posted by: Otomatic (Moderator)
Date: May 14, 2020 12:28PM


Maybe change Apache version, here with Apache 2.4.43 and deflate_module and filter_module loaded, there is no problem.

Also take the opportunity to :

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- If it is not already done, apply Update 3.2.2 to your version of Wampserver
Wampserver update 3.2.2

Wampserver 3.2.5 32 bit - Apache 2.4.46d - PHP 8.0.3…5.6.40 - MySQL 5.7.33 - MariaDB 10.5.9
Wampserver 3.2.5 64 bit - Apache 2.4.46d - PHP 8.0.3…5.6.40 - MySQL 5.7.33/8.0.23 - MariaDB 10.5.9
PhPMyadmin 5.0.4 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote

Sorry, only registered users may post in this forum.