[SOLVED] Upgrade Apache from 2.4.41 to 2.4.43
Posted by: WarriorGov9791 (---.hawaii.res.rr.com)
Date: April 05, 2020 12:02PM

Hello,

I recently installed the Apache 2.4.43 update file (as Administrator). However, upon switching to 2.4.43, the Wampserver icon stays on orange. MariaDb and MySQL are running, Apache is not.

Check State of Services
The service 'wampapache64' is not RUNNING nor STOPPED.
[SC] EnumQueryServicesStatus:OpenService failure(s) 1060 :
The specified service does not exist as an installed service.
********* The service 'wampapache64' does not exist ********

Next, I left click the WAMP icon >> Apache >> Service administration 'wampapache64' >> Install Service.

PHP command module opens with:
Your port 80 is available, Install will proceed.
Press Enter to continue...

I press Enter, command window closes.

Right click WAMP icon >> Tools >> Restart DNS. Icon remains orange.

Test Port 80
===== Tested by command netstat filtered on port 80 =====


Test for TCP
Port 80 is not found associated with TCP protocol
Port 80 is not found associated with TCP protocol

===== Tested by attempting to open a socket on port 80 =====

Your port 80 seems not actually used.
Unable to initiate a socket connection
Error number: 10060 - Error string: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


Apparently, Apache service is still not installed. I tried installing Apache version 2.4.39 (64-bit). It works out of the box. At the moment, I removed 2.4.39 and 2.4.43. I am running only 2.4.41 as it is the last version that was working for me.

Any help with the upgrade to Apache 2.4.43 is appreciated. Thank you.

Windows 10 Pro 64-bit • WAMPServer 3.2.6 64-bit
Aestan Tray Menu 3.2.4.2 • Apache 2.4.51
PHP 5.6.40 (CLI) | 7.0.33 | 7.1.33 | 7.2.34 | 7.3.33 | 7.4.26 | 8.0.13 (active) | 8.1.0 • xDebug 3.1.1
phpMyAdmin 5.1.1 • MariaDB (Default DBMS) 10.5.8 • MySQL 5.7.36 | 8.0.27
AdMiner 4.8.1 • PHPSysInfo 3.3.4 • OpenSSL 1.1.1L
Latest VC++ packages installed and verified. (VC17 14.30.30704)




Edited 5 time(s). Last edit at 04/13/2020 02:50AM by WarriorGov9791.

Options: ReplyQuote
Re: Upgrade Apache from 2.4.41 to 2.4.43
Posted by: Otomatic (Moderator)
Date: April 05, 2020 01:30PM

Hi,

> Apparently, Apache service is still not installed.
Have you checked the Service Manager after switching to Apache 2.4.43?
You can open the service manager by: Right-Click -> Tools -> Command windows -> Service Control Panel

If there are no wampapache64 service, to get more details about a possible problem, try to create the service directly on the command line:
- Open a console on the bin Apache folder:
Right-click -> Tools -> Command window -> Command windows Apache/bin
then type:
httpd -n wampapache64 -k install
Then, you have to change the starting mode of the service which, by default, is automatic by manual
sc config wampapache64 start= demand
Result:
E:\wamp64\bin\apache\apache2.4.43\bin>httpd -n wampapache64 -k install
Installing the 'wampapache64' service
The 'wampapache64' service is successfully installed.
Testing httpd.conf....
Errors reported here must be corrected before the service can be started.

E:\wamp64\bin\apache\apache2.4.43\bin>sc config wampapache64 start= demand
[SC] ChangeServiceConfig réussite(s)

E:\wamp64\bin\apache\apache2.4.43\bin>

You may have missed the Windows HTTP server Apache 2.4.43 access permission window and the Windows firewall may accept Apache 2.4.39 and 2.4.41 but not 2.4.43.
To be checked in the Windows Firewall, Allowed Applications.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.7 32 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36 - MariaDB 10.5.13/10.6.5
Wampserver 3.2.7 64 bit - Apache 2.4.51 - PHP 8.1.0…5.6.40 - MySQL 5.7.36/8.0.27 - MariaDB 10.5.13/10.6.5
PhPMyadmin 5.1.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 04/05/2020 03:03PM by Otomatic.

Options: ReplyQuote
[SOLVED] Re: Upgrade Apache from 2.4.41 to 2.4.43
Posted by: WarriorGov9791 (---.hawaii.res.rr.com)
Date: April 06, 2020 12:13AM

> Have you checked the Service Manager after switching to Apache 2.4.43?
wampapache64 is not listed


> Right-click -> Tools -> Command window -> Command windows Apache/bin
>> type: httpd -n wampapache64 -k install
Installing the 'wampapache64' service
(OS 1073)The specified service already exists. : AH00370: Failed to create the 'wampapache64' service

> Then, you have to change the starting mode of the service which, by default, is automatic by manual
>> sc config wampapache64 start= demand
[SC] OpenService FAILED 1060:
The specified service does not exist as an installed service.


> You may have missed the Windows HTTP server Apache 2.4.43 access permission window and the Windows firewall may accept Apache 2.4.39 and 2.4.41 but not 2.4.43.
>> To be checked in the Windows Firewall, Allowed Applications.

I am running Comodo Internet Security Suite. No warnings or errors ever popped up during the course of upgrading Apache. Upon further investigation, one of Comodo's features was blocking httpd.exe. After changing the File Rating to 'Trusted', re-running all of your command line suggestions and restarting DNS, the WAMP icon is green - all services running!

Thank you Oto! Stay safe, be well...

Aloha,
Ben



Edited 5 time(s). Last edit at 04/13/2020 02:51AM by WarriorGov9791.

Options: ReplyQuote


Sorry, only registered users may post in this forum.