Warning: require(/usr/share/php/wp-stack-cache.php)
Posted by: russt (---.dsl.in-addr.zen.co.uk)
Date: March 16, 2020 04:46PM

Hi
I have WAMP installed fine and have some sites up and running locally. However I have come across a problem with the latest. I'm getting the following error messages

Can anyone help??

( ! ) Warning: require(/usr/share/php/wp-stack-cache.php): failed to open stream: No such file or directory in C:\wamp64\www\welshcountry3\wp-content\mu-plugins\wp-stack-cache.php on line 21
Call Stack
# Time Memory Function Location
1 0.0003 403944 {main}( ) ...\index.php:0
2 0.0004 404232 require( 'C:\wamp64\www\welshcountry3\wp-blog-header.php' ) ...\index.php:17
3 0.0005 404584 require_once( 'C:\wamp64\www\welshcountry3\wp-load.php' ) ...\wp-blog-header.php:13
4 0.0011 406056 require_once( 'C:\wamp64\www\welshcountry3\wp-config.php' ) ...\wp-load.php:37
5 0.0012 407616 require_once( 'C:\wamp64\www\welshcountry3\wp-settings.php' ) ...\wp-config.php:99
6 0.0454 4068344 include_once( 'C:\wamp64\www\welshcountry3\wp-content\mu-plugins\wp-stack-cache.php' ) ...\wp-settings.php:291

( ! ) Fatal error: require(): Failed opening required '/usr/share/php/wp-stack-cache.php' (include_path='.;C:\php\pear') in C:\wamp64\www\welshcountry3\wp-content\mu-plugins\wp-stack-cache.php on line 21
Call Stack
# Time Memory Function Location
1 0.0003 403944 {main}( ) ...\index.php:0
2 0.0004 404232 require( 'C:\wamp64\www\welshcountry3\wp-blog-header.php' ) ...\index.php:17
3 0.0005 404584 require_once( 'C:\wamp64\www\welshcountry3\wp-load.php' ) ...\wp-blog-header.php:13
4 0.0011 406056 require_once( 'C:\wamp64\www\welshcountry3\wp-config.php' ) ...\wp-load.php:37
5 0.0012 407616 require_once( 'C:\wamp64\www\welshcountry3\wp-settings.php' ) ...\wp-config.php:99
6 0.0454 4068344 include_once( 'C:\wamp64\www\welshcountry3\wp-content\mu-plugins\wp-stack-cache.php' ) ...\wp-settings.php:291

Options: ReplyQuote
Re: Warning: require(/usr/share/php/wp-stack-cache.php)
Posted by: RiggsFolly (Moderator)
Date: March 16, 2020 04:58PM

Well now... do you have a folder called `/usr/share/php/` with a file in it called `wp-stack-cache.php`

Not likely on a windows system. It seems likely you have installed a WordPres addon when this site was on a Linux server and the addon was not written nicely so it has used and saved a linux folder structure which will never exist on a windows system

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 03/16/2020 04:58PM by RiggsFolly.

Options: ReplyQuote
Re: Warning: require(/usr/share/php/wp-stack-cache.php)
Posted by: russt (---.dsl.in-addr.zen.co.uk)
Date: March 16, 2020 05:07PM

Hi, thanks for your answer.

I don't have a folder `/usr/share/php/` with a file in it called `wp-stack-cache.php`. Is there a way around this or does it mean that I can't use this site locally?

Options: ReplyQuote
Re: Warning: require(/usr/share/php/wp-stack-cache.php)
Posted by: RiggsFolly (Moderator)
Date: March 16, 2020 05:32PM

We are not WordPress experts, or even users here.

But read this see if it helps [wordpress.org]

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Warning: require(/usr/share/php/wp-stack-cache.php)
Posted by: russt (---.dsl.in-addr.zen.co.uk)
Date: March 17, 2020 09:32AM

Thanks

Options: ReplyQuote


Sorry, only registered users may post in this forum.