I can't publish or make live my site with WAMP
Posted by: sergiu3 (92.80.249.---)
Date: March 02, 2020 02:08PM

Hello , users of WAMP , i just want to publish a site and I cant quite succeed to do so , i follow many tutorials along the way and still cant sort it out , I believe those are old and dont work anymore.
My concern is , that , I have added a virtual hosts , it appers right after i click on the wamp (left mouse click) , and it shows the server , as is working with a internet shortcut icon , but when i check it on other devices , it gaves me the error that it cannnot find the IP of the server, I have also inserted in my /drivers/etc/hosts/ file the ip 127.0.0.1 and the domain , ( with the localhost as main site of the file ) , and secondly my site right before localhost , but doenst work out , the error that appers on the server when i connect is : ERR_NAME_NOT_RESOLVED , and also I inserted into /conf/extra the file :


ServerAdmin mail@www.sportgoods.com
DocumentRoot "c:\wamp64\www"
ServerName mysite.local
ErrorLog "logs/www.sportgoods.com.log"
CustomLog "logs/www.sportgoods.com-access.log" common

(yourdomain is my site)
Do you guys have any tips, new tips of how i can solve this and help me to publish my server on-line?
It will be greatly appreciated your answers , Thanks.
My windows is 64bit,same for WAMP,my apache is 2.4.39,mysql is 5.7.26,mariaDB is 10.3.14,the color of the wamp is green when it works properly



the httpd.vhosts.conf file(including the default localhost and the other host which is the server itself)


# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>



#
<VirtualHost *:80>
ServerName www.sportgoods.com
DocumentRoot "c:/wamp64/www/sport"
<Directory "c:/wamp64/www/sport/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>

Options: ReplyQuote
Re: I can't publish or make live my site with WAMP
Posted by: RiggsFolly (Moderator)
Date: March 02, 2020 02:21PM

Look up what `Require local` does in tha Apache documentation.

Then change it according to your needs.

But only change the `www.sportgoods.com` VH and NOT the `localhost` domain

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.19>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.