Update to wamp 3.1.9 for latest PHP version at repository?
Posted by: LivingThis (---.cable.dynamic.v4.ziggo.nl)
Date: November 01, 2019 12:57PM

I would like to update WAMP to the latest version.
A reason for doing this to be able to work with PHP 7.3 .

Is the update, provided at [wampserver.aviatechno.net] (2nd paragraph) sufficient to get the same application as written ( mentioned ) under : Installers Wampserver full version, paragraph ?



Edited 1 time(s). Last edit at 11/01/2019 01:23PM by LivingThis.

Options: ReplyQuote
Re: Update to wamp 3.1.9 for latest PHP version at repository?
Posted by: Otomatic (Moderator)
Date: November 01, 2019 01:09PM

Hi,

What is mentioned?

«  This is a cumulative update. There is no need to apply the old updates 3.0.1 to 3.1.8 before applying 3.1.9. There will be no change to the Apache, PHP, MySQL, MariaDB settings and versions used; your local sites and databases will not be affected. This update will be required before install last Apache, PHP, MySQL or MariaDB addons. »

Isn't that explicit enough?
Should it be mentioned differently?
What don't you understand?

Wampserver updates only update wampmanager and, as well explained in the above text, do not modify or add Apache, PHP, MySQL or MariaDB versions.

If an Apache, PHP, MySQL or MariaDB addon requires a certain version of Wampserver, you must first update Wampserver before installing the addon.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.11/7.2.23/7.1.32/7.0.33/5.6.40 - MySQL 5.7.28 - MariaDB 10.4.9
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.11/7.2.23/7.1.32/7.0.33/5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.9
PhPMyadmin 4.9.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Update to wamp 3.1.9 for latest PHP version at repository?
Posted by: LivingThis (---.cable.dynamic.v4.ziggo.nl)
Date: November 01, 2019 01:36PM

Sorry I think the explanation is quite brief.

It could indeed be said more explicit.

Maybe its the layout that is not really clear. Small fonts and monotonous colors.

I know its me doing this.

It is possible that a number of the wamp users also has not exactly a clue what the explanation in the 2nd paragraph is about.
Most programmers learn by just testing. They try maybe both the update and the new install. You will not hear them here after that.

I learn by asking what is meant. I also learn by testing, but asking sometimes for clarification helps me judging a situation.



Edited 1 time(s). Last edit at 11/01/2019 01:48PM by LivingThis.

Options: ReplyQuote


Sorry, only registered users may post in this forum.