Are you joking about windows XP visual c++ redist and wamp compatibility?
Posted by: asocialfreak (37.48.74.---)
Date: October 20, 2019 05:30PM

Hi. You said:

"WAMPServer 3 will not run on Windows XP, by virtue of it containing Apache2.4.17+ and that requiring Microsoft Visual C/C++ Redistributable 2015 (VC14) which will not install on Windows XP. No MSVC runtimes greater than Microsoft Visual C/C++ Redistributable 2010 (VC10) will install on Windows XP"

Which I immediately noticed is not true. When we go to each visual c++ redist download page, we clearly see it says that windows xp is supported. And I have installed visualc++ redists 2005, 2008, 2010, 2012, 2013, 2015-2017 on windows xp.

Am I correct, and if I am, does wamp 3 work on windows XP?
I mean why would I keep using wamp 2.4.4 if I can use last version?
Should I download last version? I am currently using one you say is last for xp: 2.4.4.

Also I noticed that openssl from 2.4.4 does not work on windows xp.
Something about ordinal 3807 lebeay32.dll.



Edited 1 time(s). Last edit at 10/20/2019 05:36PM by asocialfreak.

Options: ReplyQuote
Re: Are you joking about windows XP visual c++ redist and wamp compatibility?
Posted by: Otomatic (Moderator)
Date: October 20, 2019 06:23PM

Hi,

> Am I correct, and if I am, does wamp 3 work on windows XP?
To know this, you would have to have a working Windows XP, which is not my case.
Therefore, Wampserver 3 installers can only be used with Windows 7 or higher.
Windows XP is obsolete and no longer supported for a long time.
That you think that the VC++ 2015-2019 (VS16) packages can be installed on XP is your responsibility, not mine.
- XP doesn't support symbolic link.
- XP is not supported by InnoSetup installer.

You can try to install these packages, then install Apache 2.4.41, PHP 7.3.10, MariaDB 10.4.8 by hand and see if it works, but I wouldn't make a Wampserver 3 Windows XP compatible installer.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.11/7.2.23/7.1.32/7.0.33/5.6.40 - MySQL 5.7.28 - MariaDB 10.4.9
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.11/7.2.23/7.1.32/7.0.33/5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.9
PhPMyadmin 4.9.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 10/21/2019 03:40PM by Otomatic.

Options: ReplyQuote


Sorry, only registered users may post in this forum.