I'm desperate con SSL
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 10, 2019 03:17PM

Do I have the latest version of wampserver and cannot access SSL from some browsers? I don't understand it rejects the connection.
I've tried everything, downloading version, uploading version ... Everything is desperate.

It seems as if some type of connection will not work.

In iexplorer or safari it works but in chorme / Firefox / Opera rejects the connection

Any ideas

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 10, 2019 03:18PM

Wamserver 3.1.9



Edited 1 time(s). Last edit at 10/11/2019 03:17PM by yanker.

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 14, 2019 03:24PM

Hi, I've been full time for more than 1 week, with this SSL and I explain everything that happens to me:

Wampserver 3.1.9 (Apache 2.4.39 + PHP 7.3.5) -> I have enabled SSL and virtualHost and it works fine locally, but remotely in chrome it fails.

I have been trying different versions of Apache, until I go down to 2.4.35 that works perfectly for me.

There has been some change in mod_sll between versions 2.4.35 and 2.4.37 that causes remote Firefox and Chrome to reject the SSL connection (without SSL everything works fine).

If I replace mod_ssl from version .35 to .37 it also works.

I would like to know if someone could guide me about what is happening, what change was made in mod_sll so that it does not work for me, it seems to be some security.

Who else has happened? Thank you

PD: 443 port open in firewall and virtual host and ssl.conf correct!

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: RiggsFolly (Moderator)
Date: October 14, 2019 04:01PM

Hi

Maybe you shoudl look at the Apache bug list to see if you can identify the bug that is causing you probelms.
It would be interesting to know

[bz.apache.org]---

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.2.0 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: Otomatic (Moderator)
Date: October 14, 2019 04:41PM

Hi,

Apache 2.4.35 -> lib SSL 1.1.0i - file 1.1.0.9
Apache 2.4.37 -> lib SSL 1.1.1a - file 1.1.1.1
Apache 2.4.38 -> idem
Apache 2.4.38b -> lib SSL 1.1.1b - file 1.1.1.2
Apache 2.4.39 -> idem
Apache 2.4.41 -> lib SSL 1.1.1c - file 1.1.1.3

Since Apache 2.4.35, the SSL library has evolved, which could explain the different problems, perhaps depending on the openSSL version with which the "keys" were generated.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.2/7.3.14/..../5.6.40 - MySQL 5.7.29 - MariaDB 10.4.12
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.2/7.3.14/..../5.6.40 - MySQL 5.7.29/8.0.19 - MariaDB 10.4.12
PhPMyadmin 5.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 15, 2019 09:31AM

I have also weighed that after days and days isolating errors, I have come to think that it must be openSSL, it is possible to mount an Apache 2.4.41 + OpenSSL lib SSL 1.1.0i - file 1.1.0.9 ??

Would this be correct?

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: Otomatic (Moderator)
Date: October 15, 2019 10:52AM

Hi,

>it is possible to mount an Apache 2.4.41 + OpenSSL lib SSL 1.1.0i - file 1.1.0.9 ??

I think it's possible, without prejudging the results, but it's never a good thing to mix versions of libraries in an Apache distribution.
I think we should replace the library libssl-1_1-x64.dll (or libssl-1_1.dll) and maybe also libcrypto-1_1-x64.dll (or libcrypto-1_1.dll)

There is also "openssl.exe" which has evolved between the different Apache versions.

I don't think it's the right solution to mix versions.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.2/7.3.14/..../5.6.40 - MySQL 5.7.29 - MariaDB 10.4.12
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.2/7.3.14/..../5.6.40 - MySQL 5.7.29/8.0.19 - MariaDB 10.4.12
PhPMyadmin 5.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: I'm desperate con SSL
Posted by: yanker (---.122.14.37.dynamic.jazztel.es)
Date: October 15, 2019 01:52PM

You're right, I think I will finally work with Apache 2.4.35 + PHP 7.3.10 that works well for me and in the future I will update that there will be a solution.

Thank you

Options: ReplyQuote


Sorry, only registered users may post in this forum.