Error: Unrecognized parameter name WAMPMYSQLOFFName
Posted by: Rapoirot (---.genericrev.cantv.net)
Date: September 02, 2019 09:41PM

Hi!

I have this problem. when I click on wampserver icon, a pop up windows appears with this message :

"The configuration file contains a syntax error on line 27: Unrecognized parameter name WAMPMYSQLOFFName"


I am using wampserver64 3.1.7

Can somebody help me?

thanks!



Edited 2 time(s). Last edit at 09/02/2019 10:07PM by Rapoirot.

Options: ReplyQuote
Re: Error: Unrecognized parameter name WAMPMYSQLOFFName
Posted by: Rapoirot (---.genericrev.cantv.net)
Date: September 02, 2019 10:01PM

My wampmanager.ini file:


[Config]
;WAMPCONFIGSTART
ImageList=images_off.bmp
ServiceCheckInterval=1
ServiceGlyphRunning=13
ServiceGlyphPaused=14
ServiceGlyphStopped=15
TrayIconAllRunning=16
TrayIconSomeRunning=17
TrayIconNoneRunning=18
ID={wampserver}
AboutHeader=WAMPSERVER 3.1.7 32bit
AboutVersion=Version 3.1.7
;WAMPCONFIGEND

[AboutText]
WampServer
Created by Romain Bourdon
Wampserver 3 by Otomatic
wampmanager.ini minimum file to recreate
the original file

[Variables]

[Services]
Name: APACHESERVICE
WAMPMYSQLOFFName: MYSQLSERVICE
WAMPMARIADBOFFName: MARIADBSERVICE


[Messages]
AllRunningHint=WAMPSERVER - All services running
SomeRunningHint=WAMPSERVER - %n of %t services running
NoneRunningHint=WAMPSERVER - None of %t services running

[StartupAction]
;WAMPSTARTUPACTIONSTART
Action: run; FileName: "WAMPROOT/bin/php/phpWAMPPHPVERSIONCLI/php-win.exe";Parameters: "refresh.php";WorkingDir: "WAMPROOT/scripts"; Flags: waituntilterminated
Action: resetservices
Action: readconfig

Action: service; Service: APACHESERVICE; ServiceAction: startresume; Flags: ignoreerrors
WAMPMYSQLOFFAction: service; Service: MYSQLSERVICE; ServiceAction: startresume; Flags: ignoreerrors
WAMPMARIADBOFFAction: service; Service: MARIADBSERVICE; ServiceAction: startresume; Flags: ignoreerrors


;WAMPSTARTUPACTIONEND



Edited 1 time(s). Last edit at 09/02/2019 10:04PM by Rapoirot.

Options: ReplyQuote
Re: Error: Unrecognized parameter name WAMPMYSQLOFFName
Posted by: Otomatic (Moderator)
Date: September 02, 2019 10:37PM

Hi,

The error you have as well as the content of the file wampmanager.ini shows that the installation was not carried out correctly, the installation VARIABLES were not replaced by their true values, for example, WAMPROOT should have been replaced by the actual installation path, for example c:/wamp64
It seems that you did not launch the installer as an administrator.

- 1 - Uninstall Wampserver.

- 2 - Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- 3 - Install Wampserver 3.1.9 as an administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.4.7
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.4.7
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.