WampServer 3.1.9 BackupHosts error msg
Posted by: servinfma (190.104.112.---)
Date: August 08, 2019 09:03PM

I have joomla 3.9.10 running smoothly right now. The only situation I have is that whenever I start the wampserver (without starting joomla, only wampserver), in the file "php.error.log" which is in the directory "c: \ wamp \ logs", the following message is shown: "[08-Aug-2019 18:56:14 UTC] PHP Notice: Undefined index: BackupHosts in C: \ wamp \ scripts \ refresh.php on line 2113", I don't know if this is a problem, what is the reason of this msg and how can i remove it ?? Thanks for your help.

Options: ReplyQuote
Re: WampServer 3.1.9 BackupHosts error msg
Posted by: Otomatic (Moderator)
Date: August 08, 2019 09:22PM

Hi,

There is no problem for you.

Please see the message in the top of the forum READ (and answer) BEFORE ASK A QUESTION.

I need your answers to see where the problem is.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.1.9 BackupHosts error msg
Posted by: servinfma (190.104.112.---)
Date: August 09, 2019 06:48AM

Sorry for not reading before and not sending the 13 responses. Now I know.

You said that this does not represent a problem for my site, but you wanted to see the answers to see what the problem is, here I sent them to know why it displays that message. Thank you

1 - Windows version used (Specify version number AND whether 32 or 64 bit) : Windows 7 Pro 32Bits
2 - Version WampServer (Specify version number AND whether 32 or 64 bit): 3.1.9 32Bits
3 - Apache Version: 2.4.39
4 - PHP Version: 7.1.29
5 - MySQL Version: 5.7.26
5a - MariaDB version if applicable: Not using it.
6 - What color is the WampServer icon (in the notification area of the taskbar): Green
7 - In the file c:\Windows\System32\drivers\etc\hosts, what are the active lines?
* Active means no # at the beginning of the line.

::1 localhost
127.0.0.1 localhost

If the WampServer icon is green:

8 - Do you have access to localhost (Homepage WampServer)? Yes, all runs ok.
8a - If so, is there an error message at the bottom of the page? Not at the botton of the page...in php.error.log

9 - Do you have access to phpMyAdmin? Yes

10 - If you refer to an error message, please include the EXACT wording of the error in your post: "[08-Aug-2019 18:56:14 UTC] PHP Notice: Undefined index: BackupHosts in C: \ wamp \ scripts \ refresh.php on line 2113"
11 - If you use an Antivirus and / or Firewall, please include the names of these: AVG and Windows Firewall
12 - What is the full path to the installation of WampServer (eg D:\wamp\) c:\wamp
13 - If you have one or more Virtual Hosts defined, please show their definition(s): I don't have any.

Options: ReplyQuote
Re: WampServer 3.1.9 BackupHosts error msg
Posted by: Otomatic (Moderator)
Date: August 09, 2019 09:31AM

Hi,

This is just a warning and not a consequence.
However, this could be an error or a missing item in language file:
wamp(64)\lang\modules\settings_english.php

In the Right-Click -> Wamp settings menu, is there an item :
Backup hosts file

If no, check in file wamp(64)\lang\modules\settings_english.php if there is for the array $w_settings:
.....
'BackupHosts' => 'Backup hosts file',

If so, this shows that the corresponding index does not exist in your language file if you use a language other than English.

It could also be that there is an algorithm flaw in the loading of language files because if an index does not exist in the language file used, then the index of the English language file is used.

Ignore this warning until the next update of Wampserver which should fix this defect.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.1.9 BackupHosts error msg
Posted by: Otomatic (Moderator)
Date: August 09, 2019 10:55AM

Hi,

There is indeed an algorithm flaw in the management of language files. I didn't realize this earlier because my own English and French language files have no errors or missing items.
Will be fixed with the Wampserver 3.1.10 update that will be required to support PHP 7.4.0.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: WampServer 3.1.9 BackupHosts error msg
Posted by: servinfma (190.104.112.---)
Date: August 15, 2019 09:28PM

Thanks for your reply.
"In the Right-Click -> Wamp settings menu, is there an item: Backup hosts file ", there is no file with that name.
Since it does not represent any problem in the performance and operation of my WampServer, I will wait for the correction in the new update as you suggest.
Thanks for your support.
I don't know and I can't find how to close this incident, please close it. Thank you.

Options: ReplyQuote


Sorry, only registered users may post in this forum.