PHP Version 7.3.7 doesn't work
Posted by: martinvanstein (---.cable.dynamic.v4.ziggo.nl)
Date: July 20, 2019 03:49PM

I have a strange thing happening at the moment, where when I try to use PHP Version 7.3.7 , the page doesn't want to load and I get the message:

This site can't be reached
The connection was reset

Try:

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_RESET.

However when I load version 7.3.5 it kind of works ... I say kind of because I get all these php error codes ( which is understandable as my webpage runs on 7.3.7

Initially I did an upgrade but because I got the above error I thought that I should probably do a fresh install ... I did all the double checks with regards to the Visual C++ frameworks and that should be fine ... and yes even for the add on which required 2 of these things I installed both 32 & 64 bit packages .

Now it may be that I am missing something simple ... however I haven't got these issues when I migrate the site to another live site , so it must be something within WAMP or even the add on that doesn't work properly

Anyway any help is appreciated

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 20, 2019 04:08PM

Hi,

> the page doesn't want to load
- What page ?
- Is the page you want to load compatible with PHP 7.3.7?

> I did all the double checks with regards to the Visual C++
- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: martinvanstein (---.cable.dynamic.v4.ziggo.nl)
Date: July 20, 2019 04:20PM

Hey Otomatic,

With the page I mean the entire website simply doesn't want to load ... from the home page to the admin area.

And yes the page is definitely compatible with 7.3.7 as when I migrate the site to another domain I own which runs 7.3.7 as well, it works just fine

I used the tool to check if I had all necessary VC++packages installed and that was all okay and I downloaded everything from aviatechno site.
And I installed each package as an admin too

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 20, 2019 05:54PM

Hi,

I could only advise you to use a more recent Apache version, for example 2.4.39. The different Apache versions are also available at [wampserver.aviatechno.net]

As far as I'm concerned, I didn't have these problems, but I still use the latest Apache version.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 21, 2019 09:18AM

I have exactly the same problem with PHP7.3.7.
I have run the VC++ packages checking tool and it reports all VC++ packages are installed.
On my wamp server, I have several sites all of which run perfectly on PHP7.3.6 but switching to PHP7.3.7 causes some of the pages to not load with the same error message ...

This site can't be reached
The connection was reset

I have also installed the latest version of apache which does not help.
And I have two of the sites on a live server running PHP7.3.7 with no issues?

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 21, 2019 09:38AM

Hi,

You return to PHP 7.3.5 or 7.3.6 and report a bug on the php.net site.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 21, 2019 11:22AM

I would except that PHP7.3.7 works without issues on a live server, it only errors on my wamp server?
The php.net admins will say post a bug on the wampserver site!
Perhaps I will wait to see if more members report this issue whilst I carry on trying to debug this.
Thanks for your help...

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 21, 2019 12:35PM

I have 7.3.7 working now...

I downloaded php-7.3.7-Win32-VC15-x64 from the php.net downloads page and extracted it to a temporary folder in my downloads folder
.
I then copied the entire contents of the temporary folder and pasted them into my wamp/bin/php/php73.7 folder overwriting the existing files and folders...

I then restarted wamp server and voila, no more errors in PHP7.3.7.

I hope this helps someone...

Re: PHP Version 7.3.7 doesn't work
Posted by: martinvanstein (---.cable.dynamic.v4.ziggo.nl)
Date: July 21, 2019 03:30PM

Awesome Weyboat ... that worked for me too !

And for people too lazy to look for the exact link : [windows.php.net]

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 21, 2019 05:55PM

I have found that just replacing the php_opcache.dll file in the wamp/bin/php/php7.3.7/ext folder with the newly downloaded version fixes the issue for me.
I have run WinMerge to check the difference between the installed wampserver3_64_addon_php7.3.7 and the downloaded version from php.net and there are a lot of differences between them.

I suppose the safest thing to do is replace all existing files and folders as we have already done but the real culprit could be just the php_opcache.dll file.

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 21, 2019 07:02PM

Hi,

The zip file has been modified surreptitiously since it was first made available on the php.net website.
For example, the extension php_opcache.dll, although still noted as 7.3.7.0, has changed in size and release date.
first available : 463872 bytes - 02/07/2019 16:42
last available : 463488 bytes - 03/07/2019 17:33

I am not responsible for changes to php.net files without any version changes or explanations.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 21, 2019 08:37PM

Hi,

Do you think I should recompile the PHP 7.3.7 addons?

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: martinvanstein (---.cable.dynamic.v4.ziggo.nl)
Date: July 21, 2019 08:53PM

Hey,

Recompile or post the link to this post below the 7.3.7 download ... it really depends on how many people use this particular version of PHP vs the amount of work I guess winking smiley

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 21, 2019 08:58PM

I had a feeling that the files had been modified since you downloaded them for compilation.
In answer to your question... Yes, I think you have no choice but to recompile the 7.3.7 addons now that you are aware of this issue.

If you post here when that is completed I will download the new files and test them on my wampserver install.

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 21, 2019 10:06PM

Hi,

The new recompiled PHP 7.3.7 addons are available, with explanation, at http://wampserver.aviatechno.net as well as on Sourceforge.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 21, 2019 10:43PM

The recompiled addon is still using the files dated 2/7/2019?
The downloaded files from php.net are dated 3/7/2019 so the recompiled addon is still faulty.

Could you check your file dates, please

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 22, 2019 11:07AM

Hi,

To avoid any controversy and to do exactly like all Wampserver users, I applied, under Windows 10 Pro 64bit, the following procedure for my two versions of Wampserver ( 32 and 64 bit):
- Back to PHP 7.3.6
- Delete PHP 7.3.7
-- Right-click -> Tools -> Delete unused versions -> Delete PHP 7.3.7
- Exit Wampserver

- Download new PHP 7.3.7 addons from wampserver.aviatechno.net
PHP 7.3.7 32 bit x86
PHP 7.3.7 64 bit x64

- Install previously downloaded addons
PHP 7.3.7 32 bit x86
PHP 7.3.7 64 bit x64

- Check the dates of the files:
They are well dated July 3, 2019

CQFD - What had to be demonstrated.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: PHP Version 7.3.7 doesn't work
Posted by: weyboat (---.range86-168.btcentralplus.com)
Date: July 22, 2019 11:46AM

Yes, that was exactly the same procedure that I followed.
I tried this 3 times with the same result, (files dated 02/07/2019).

So this time I also cleared my browser cache whilst on the wampserver.aviatechno.net site and refreshed the page and this time the files are indeed dated 03/07/2019?

Is it possible I was being served a file from my browser's cache?

Anyway, all is well now thank you.

Re: PHP Version 7.3.7 doesn't work
Posted by: Otomatic (Moderator)
Date: July 22, 2019 03:03PM

Hi,

> Is it possible I was being served a file from my browser's cache?

I doubt it.
The old addons have been replaced by the new ones, so the old files no longer exist on the server.
If a link to the cache still existed, it is the new addon that should have been downloaded.

------------------------------------------------------------------------------------------------------------
Wampserver 3.2.0 32 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28 - MariaDB 10.4.10
Wampserver 3.2.0 64 bit - Apache 2.4.41 - PHP 7.4.0/7.3.12/..../5.6.40 - MySQL 5.7.28/8.0.18 - MariaDB 10.4.10
PhPMyadmin 4.9.2 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Sorry, only registered users may post in this forum.