Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: FuzMic (---.static.tpgi.com.au)
Date: June 26, 2019 03:41AM

Hi gurus

I have no problem if i download files & mysql db from Hostgator and run it from wamp.

However if i download from Heliohost.org, running the related 'Virtual Host', it will just cause a download as a file which is actually the index.php of webpage.

I have already disabled the .htaccess which is have extra line of
<IfModule mime_module>
AddType application/x-httpd-ea-php56 .php .php5 .phtml
</IfModule>

Hope to learn why. Thank You

Options: ReplyQuote
Re: Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: RiggsFolly (Moderator)
Date: June 26, 2019 12:36PM

Hi,

PHP file downloading as source is normally due to a config error.

Out of interest can you post your `<Virtual Host..>` definitions

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: FuzMic (---.static.tpgi.com.au)
Date: June 26, 2019 11:09PM

Good morning Chris from right down under


By definitions i assume the content in httpd-vhosts.conf

<VirtualHost *:80>
	ServerName localhost
	DocumentRoot c:/wamp64/www
	<Directory  "c:/wamp64/www/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>


<VirtualHost *:80>
	ServerName eatery.local
	DocumentRoot "c:/wamp64/www/cye"
	<Directory  "c:/wamp64/www/cye/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>


<VirtualHost *:80>
	ServerName p2u.local
	DocumentRoot "c:/wamp64/www/p2u"
	<Directory  "c:/wamp64/www/p2u/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>


All V.host work except the last one ie p2u.local which dump the index.php instead

Kind Regards



Edited 1 time(s). Last edit at 06/26/2019 11:17PM by RiggsFolly.

Options: ReplyQuote
Re: Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: FuzMic (---.static.tpgi.com.au)
Date: June 26, 2019 11:18PM

Just found that the browser response is

peace2u.local's server ip address not found

The vhost is actually p2u.local (not peace2u)

Options: ReplyQuote
Re: Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: RiggsFolly (Moderator)
Date: June 26, 2019 11:21PM

Hi,

Well that looks fine.

Ok so did you build the helio site using some kind of site builder tool/feature or did you build the site in the usual way with wordpress or raw php.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: FuzMic (---.static.tpgi.com.au)
Date: June 27, 2019 12:13AM

Mate

It was built in wamp years ago using Joomla in its localhost; then uploaded files & mysql to Heliohost's server.

The Peace2u site has been running for 2 years without any problem. Joomla version is constantly upgraded to the latest version together with the latest version of extensions & plugin, running without any issue.


i recently download the files and mysql.db from Helio and copy/import to wamp local host, then the issue pops up. This same process is being used for hostgator & there is no problem as stated in the start of this thread.

Thanks for following

Options: ReplyQuote
Re: Heliohost download won't work in wamp v3.1 64b php 7.1
Posted by: FuzMic (---.static.tpgi.com.au)
Date: June 28, 2019 01:02AM

Chris for some reason when i browse from ucbrowser it works, thereafter also work in chrome - on one day after.

I don't know why perhaps i force clean cache in the site files.

Anyway from old memory similar event happen before due to .htaccess that was i why i make reference to it in the start of this thread.

Options: ReplyQuote


Sorry, only registered users may post in this forum.