failed access from other computer,smartphone on same network and internet
Posted by: countll (115.132.47.---)
Date: June 22, 2019 04:37PM

1.setup all working find no error. i want to make it access to internet but i cant even access it via other computer and handphone on the same network.
im running on dynamic ip address. i tried to port foward and got account on no-ip.com .but none bot working
can you help channel me to where i can get it done..been googles everywhere but cant find the one success followed.only success on this computer all setup workpress mysql php.
im beginner since 1 week.

maybe port foward is not ok coz wampserver working charmed.
been using aztech 5028EN 2t2r
please help my brain stuck

Thank you very much sir

1.mywampserver3.19_x64
2.apache2.4.39
3.mariadb10.3.14
4.mysql5.7.26
5.php7.3.5
6.colour green
7.hosts
127.0.0.1 localhost
127.0.0.1 localhost localhost.localdomain
127.0.0.1 ServerHost host.apache.local
127.0.0.1 ServerStatus stat.apache.local
127.0.0.1 ServerInfo info.apache.local
127.0.0.1 localhost
::1 localhost
::1
127.0.0.1 wordpress
::1 wordpress
127.0.0.1 countll.ddns.net
::1 countll.ddns.net

8. yes has all working fine apache,mysql,php
9.yes to phpmyadmin
10.no error
11.window defender
12.C:\wamp64\
13.vhost-
# Virtual Hosts
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>

<VirtualHost *:80>
DocumentRoot "C:/wamp64/www/wordpress"
ServerName wordpress
<Directory "C:/wamp64/www/wordpress">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>
#
<VirtualHost *115.132.47.31:80>
ServerName countll.ddns.net
DocumentRoot "c:/countll.ddns.net"
<Directory "c:/countll.ddns.net/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
Require all granted
require ip 192.168.1.1
</Directory>
php_flag display_errors Off
php_flag log_errors On

php_value max_upload_size 40M
php_value max_execution_time 120
php_value error_log "C:/wamp64/logs/countll_ddns_net_phperror.log"

</VirtualHost>



Edited 2 time(s). Last edit at 06/23/2019 08:58AM by countll.

Re: failed access from other computer,smartphone on same network and internet
Posted by: RiggsFolly (Moderator)
Date: June 24, 2019 11:40AM

Hi

the first thing that comes to mind is

<VirtualHost *115.132.47.31:80>

Either use `*:80` or `115.132.47.31:80` I would suggest sticking with

<VirtualHost *:80>

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Sorry, only registered users may post in this forum.