Ran check_vcredist.exe before installing WAMP 3.1.9 on Win10
Posted by: mxsquid (---.lsv2.qwest.net)
Date: May 15, 2019 07:52PM

I attempted to install vcredist_2019_x86.exe in a Win 10 environment because of this error message:


VC_2019_REDIST_X86 ID={B96F6FA1-530F-42F1-9F71-33C583716340}

Visual C++ 2015-2019 x86 Minimum Runtime- 14.20.27508

**** NOT INSTALLED ****

Installation file is on: [wampserver.aviatechno.net]


At 50% completion and after waiting an additional 2 hours, I finally killed the install shown on the screenshot

[finditgroup.org]


Here's my log file named dd_vcredist_x86_20190514100720.log

[finditgroup.org]


How long should the install take? Would someone kindly interpret these lines?

B96F6FA1-530F-42F1-9F71-33C583716340}v14.20.27508\packages\vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi, arguments: ' MSIFASTINSTALL="7" NOVSUI="1"'
[064C:2010][2019-05-14T11:57:41]e000: Error 0x80070642: Failed to install MSI package.

Re: Ran check_vcredist.exe before installing WAMP 3.1.9 on Win10
Posted by: Otomatic (Moderator)
Date: May 15, 2019 08:52PM

Hi,

Original Microsoft files are :
- x86
[aka.ms]
- x64
[aka.ms]

It take less than one minute for each, may be asked for restart the system.

Right-click on the file then Run as an administrator.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.4.7
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.4.7
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: Ran check_vcredist.exe before installing WAMP 3.1.9 on Win10
Posted by: mxsquid (---.lsv2.qwest.net)
Date: May 16, 2019 08:28PM

Thank you Otomatic. I may have solved my own problem by downloading the 2019 VC redistributables from the Microsoft Visual Studio official site. After downloading vc_redist_86.exe and vc_redist_x64.exe, I renamed the files with prefixes ms2019-. Note also the file sizes. This seemed to work for me as the software I downloaded ran to completion. I suggest that the admins at aviatechno update their info [wampserver.aviatechno.net]


ms2019-vc_redist.x86.exe 14,091 KB
ms2019-vc_redist.x64.exe 14,769 KB


I'm being very cautious about my Wampserver 3.1.9 installation.

Re: Ran check_vcredist.exe before installing WAMP 3.1.9 on Win10
Posted by: Otomatic (Moderator)
Date: May 17, 2019 09:56AM

Hi,

- File http://wampserver.aviatechno.net/files/vcpackages/vcredist_2019_x86.exe
Size : 14 428 336 Bytes
MD5 : A0A3ADF7D82BC07D8C33471EA9B8D4F6
- File https://aka.ms/vs/16/release/VC_redist.x86.exe
Size : 14 428 336 Bytes
MD5 : A0A3ADF7D82BC07D8C33471EA9B8D4F6
The files are strictly identical

- File http://wampserver.aviatechno.net/files/vcpackages/vcredist_2019_x64.exe
Size : 15 123 392 Bytes
MD5 : EDAF52B1F182D245952EB68CC7D52A3B
- File https://aka.ms/vs/16/release/VC_redist.x64.exe
Size : 15 123 392 Bytes
MD5 : EDAF52B1F182D245952EB68CC7D52A3B
The files are strictly identical

> I suggest that the admins at aviatechno update their info
There's nothing to update! All information about these files on'wampserver.aviatechno.net' is correct.

When talking about file sizes, it is important to be consistent with the units used and not to mix apples and pears.
For example, you specify "14769 KB" for the 64 bit file, which corresponds to "15123392/1024" which should therefore be written "14769 kiB" and even, to be exact: "14768.9375 kiB"
If you wanted to use kB (kiloBytes) you would have to write "15123 kB".
In addition, using rounded values to define and compare file sizes is an aberration.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.4.7
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.9/7.2.22/7.1.32/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.4.7
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Re: Ran check_vcredist.exe before installing WAMP 3.1.9 on Win10
Posted by: mxsquid (---.lsv2.qwest.net)
Date: May 20, 2019 07:45PM

Odd occurrence I encountered re: vcredist_2019_x86, _x64 Dominique, but I did get WAMP 3.1.9 to work once I downloaded from Visual Studio. Thank you for kind support.

Sorry, only registered users may post in this forum.