Wamp server not working in chrome, opera and explorer browsers
Posted by: chinwa (197.210.52.---)
Date: April 24, 2019 03:02PM

Please am new in this forum and this is my first post, I installed wamp server , the wamp icon turns green when started, my php works well in Mozilla Firefox, but my issue is that it doesn't work in other browsers (opera, explorer, chrome) . Whenever I try to open my " .php file " in opera, chrome and explorer browsers It only open a completely white / blank page.
Please I need assistance. My coding is correct, it's all html codes but saved as php file. I was trying to test the wamp server with this ".Php file "

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: RiggsFolly (Moderator)
Date: April 25, 2019 11:08AM

Hi,

Can you try using `127.0.0.1` instead of `localhost` in the address bar of the browsers that are not showing your html pages please.

Does that work?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: Otomatic (Moderator)
Date: April 25, 2019 11:53AM

Hi,

> Whenever I try to open my " .php file " in opera, chrome and explorer browsers...

How do you try to "open" the .php file?

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: chinwa (197.210.227.---)
Date: April 25, 2019 01:16PM

I open it from my html editor (dreamweaver) file >preview in browser .

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: chinwa (197.210.227.---)
Date: April 25, 2019 01:19PM

The point is, whenever I try to open the php file in a browser it tries to download the file instead of opening it as a web file

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: Otomatic (Moderator)
Date: April 25, 2019 01:52PM

Hi,

> I open it from my html editor (dreamweaver) file >preview in browser .
You put your file in a folder itself located in wamp(64)\www\, for example wamp(64)\www\mysite\myfile.php

And you launch your file by typing in the address bar of the browser: 'http://localhost/mysite/myfile.php'

But, the solution is to use VirtualHost for your local sites, as with all hosting providers.
See The need for Virtual Host

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: chinwa (197.210.28.---)
Date: April 25, 2019 08:59PM

I have a virtual host(wamp server) it turns green when I click start. My file is saved in my web folder which is in the www folder.

Options: ReplyQuote
Re: Wamp server not working in chrome, opera and explorer browsers
Posted by: Otomatic (Moderator)
Date: April 26, 2019 08:58AM

Hi,

> I have a virtual host(wamp server)
No, it is a server web, not a VirtualHost.
You didn't read The need for Virtual Host

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.