"error in the httpd-vhost.conf - 443 is not a listen port"
Posted by: drakir (---.ling.su.se)
Date: April 11, 2019 04:16PM

Hi

My wampserver seem to work just fine but when I click on the server icon and then on 'your virtualhosts' I have
an error notification for mysite.whatever.se:443. When I click on the notification the promt window says;

"Sorry, there's an error in the httpd-vhost.conf file. The port used for the Virtualhost mysite.whatever.se is not a listen port...."

Does anyone know whats' up with that?

I've have Listen 443 in my conf-ssl and I have *:443 in my Virtualhost configuration. I have also checked the firewall settings and as I said - every thing seem to work

Options: ReplyQuote
Re: "error in the httpd-vhost.conf - 443 is not a listen port"
Posted by: Otomatic (Moderator)
Date: April 11, 2019 04:32PM

Hi,

Hi,

In this thread [forum.wampserver.com] you have an example of a fully functional httpd-ssl.conf file.

In your httpd-vhosts.conf file do not mix the "normal" VirtualHost on port 80 with the VirtualHost https on port 443.
Reserve, as in the example above, the VirtualHost port 443 for the file httpd-ssl.conf.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.8 32 bit - Apache 2.4.39 - PHP 7.3.4/7.2.17/7.1.28/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.14
Wampserver 3.1.8 64 bit - Apache 2.4.39 - PHP 7.3.4/7.2.17/7.1.28/7.0.33/5.6.40 - MySQL 5.7.25/8.0.15 - MariaDB 10.3.14
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.