OpenSSL not working
Posted by: JG (---.cable.dynamic.v4.ziggo.nl)
Date: April 10, 2019 05:36PM

I still had an older wampserver 3 version (32 bit) with only php 5.6 running and decided to (finally) upgrade to PHP 7 on my win10 computer. First I updated wampserver with update package 3.1.8 and then I added the latest PHP versions 7.2 (which is 7.2.16) according the instructions in this forum.

Earlier, I had updated my own source code to get rid of deprecated and removed functions and everything seems to run fine.

I only have a problem with OpenSSL (to replace older mcrypt functions, that have been removed in php7.2).

However, I got stuck with the php error 'Call to undefined function openssl_cipher_iv_length()'.

I checked the PHP extensions (using left click on the wamp icon in the sys tray) and it said that openssl was enabled.
Looking at phpinfo() output, however, it said that openSSL was disabled.

What more can I do, to make opsenssl working (which did run on wampserver with php 5.6 earlier this week).


Many thanks!
John

Options: ReplyQuote
Re: OpenSSL not working
Posted by: JG (---.cable.dynamic.v4.ziggo.nl)
Date: April 10, 2019 06:22PM

Googling a bit more, I found one suggestion to copy the libeay32.dll and ssleay32.dll files from the working php 5.6 version into the php 7.2 directory.

I found these two dlls in bin/php/php5.6.15 and copied them in bin/php/php7.2.16 directory and restarted wamp as instructed.

Unfortunately it still doesn't work.

It still works with php 5.6, but not with 7.2.

phpinfo also still lists: disabled (install ext/openssl)
But this is enabled according wampserver (see original post above)

Any ideas?

Options: ReplyQuote
Re: OpenSSL not working
Posted by: JG (---.cable.dynamic.v4.ziggo.nl)
Date: April 10, 2019 07:21PM

Got it solved by just proceeding with the other updates.

I also updated Apache to the latest version and checked whether this had an ssl module in its list with modules (left click on wamp icon in the systray and then selecting apache and then selecting apache modules).

Probably, this comes with a later version for opsenssl (I gues). Anyway, it works now!

Thanks for your help, it was nice talking to my self. smiling smiley

Hopefully, someone else benefits from the above aswell, now or in the future.

Options: ReplyQuote
Re: OpenSSL not working
Posted by: Otomatic (Moderator)
Date: April 10, 2019 08:07PM

Hi,

> Googling a bit more, I found one suggestion to copy the libeay32.dll and ssleay32.dll files
> from the working php 5.6 version into the php 7.2 directory.
This is another huge bullshit for the internet tutorials and explanations about Apache and PHP.
Don't believe all the PHP explanations found on the Internet about PHP or Apache or SSL, it's 95% shit and it allows you to destroy your installation very easily.

Your bedside books must be the official Apache, PHP, MySQL and MariaDB documentation.
RTFM
The links are in the menu items of Wampmanager.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.6/7.2.19/7.1.30/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.15
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.6/7.2.19/7.1.30/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.15
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.