Looking for a specific version of wampserver
Posted by: oquinena (---.227.181.62.in-addr.dgcsystems.net)
Date: March 12, 2019 10:53AM

I'm looking for a specific version of the installation program that are no longer available from wampserver.com. Namely wampserver3.0.4_x64_apache2.4.18_mysql5.7.11_php5.6.19-7.0.4.exe. Anyone happen to have a link to where I can download that specific file from?

Thank you!

Options: ReplyQuote
Re: Looking for a specific version of wampserver
Posted by: Otomatic (Moderator)
Date: March 12, 2019 10:58AM

Hi,

Not available.
Install Wampserver 3.1.7 then add Apache, PHP, MySQL versions you want.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Looking for a specific version of wampserver
Posted by: RiggsFolly (Moderator)
Date: March 12, 2019 10:59AM

Hi,

Download the latest WAMPServer, currently V3.1.7

Then go to the WAMPServer backup Repo WAMPServer backup Repo


Now if you want to use specific version fo Apache MySQL and PHP then just download the specific ADDON's for those versions.

Then switch to those versions using the WAMPServer icon menu

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.7 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 2 time(s). Last edit at 03/12/2019 11:00AM by RiggsFolly.

Options: ReplyQuote
Re: Looking for a specific version of wampserver
Posted by: oquinena (---.227.181.62.in-addr.dgcsystems.net)
Date: March 12, 2019 12:05PM

Unfortunatly that's not really an option at the moment. We have som legacy code dependent on that specific installation file. Rewriting those parts is not possible within the time span I have to install.

Options: ReplyQuote
Re: Looking for a specific version of wampserver
Posted by: Otomatic (Moderator)
Date: March 12, 2019 03:28PM

Hi,

Your code may be dependant of versions of Apache, PHP or MySQL but is NEVER dependant of Wampserver version.
So, I repeat :
Install Wampserver 3.1.7 then the addons of Apache, PHP and MySQL you need. Launch Wampserver, then switch to theses versions with Wampmanager menu items like Left-click Apache Version and the same for PHP and MySQL.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.