php 5.6 (5.5?) ssh2_connect unavailable
Posted by: relipse (---.mdtnwi.dedicated.static.tds.net)
Date: February 04, 2019 05:25PM

Hi,
I tried installing the ssh2 extension with PHP 5.6 but it is failing.

[04-Feb-2019 16:18:04 UTC] PHP Warning: PHP Startup: ssh2: Unable to initialize module
Module compiled with module API=20121212
PHP compiled with module API=20131226
These options need to match
in Unknown on line 0

The version I downloaded was for php 5.5 on this page: [pecl.php.net]
because there was no php 5.6 version.

If this is the reason why it is not working, then how can I get php 5.5 on wamp or find a ssh2 version that works with php 5.6.35

I'm on WAMP 3.1.3
Thanks for responding.

Options: ReplyQuote
Re: php 5.6 (5.5?) ssh2_connect unavailable
Posted by: Otomatic (Moderator)
Date: February 04, 2019 05:52PM

Hi,

WAMPserver 3 - All you need to know
you will be able to see all the PHP versions available in "addon" for Wampserver 3.
It goes from PHP 5.3.5 to PHP 7.3.1

As for an ssh2 file for PHP 5.6, it is with PHP that we must ask the question, here we can create addons for PHP versions, but we don't create ssh2 file.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.41 - PHP 7.3.8/7.2.21/7.1.31/7.0.33/5.6.40 - MySQL 5.7.27/8.0.17 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: php 5.6 (5.5?) ssh2_connect unavailable
Posted by: relipse (---.mdtnwi.dedicated.static.tds.net)
Date: February 04, 2019 07:47PM

I just wanted to let you know I found a SSH2 dll here: [phpfashion.com]

I used the x64 version for php 5.6 and that worked. Thank you for your help anyway

Options: ReplyQuote


Sorry, only registered users may post in this forum.