Accessing Wamp Server from iPad [SOLVED]
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 12:03PM

I must be doing something fundamentally wrong, but having followed every bit of advice I can find about setting up a virtual host, etc., I cannot access my development website on the laptop connected via wifi to my network from my iPad connected to the same network. I just get the "Safari could not open the page because the server stopped responding" message. I cannot get past it, so what fundamental step am I missing?

Thanks!



Edited 1 time(s). Last edit at 01/02/2019 04:26PM by AliGW.

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: RiggsFolly (Moderator)
Date: January 02, 2019 12:24PM

Hi,

Have a read of this My answer to a question on StackOverflow

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.7 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 12:28PM

OK - I will try this again. Will you help me, though, if I still can't make it work? I have been at this since 8am and have made no progress. sad smiley

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 12:49PM

Still no luck. I have followed your instructions to the letter again, and nothing. Do I need to set up port forwarding on my router for 8000? If so, I already think I did this for port 80 (I have Sky Broadband) and it made no difference.

I reached out to you here because I am getting very frustrated. I am usually able to work these things out for myself, but on this occasion, I have hit a brick wall. You are probably thinking that I haven't read things properly and that I have missed something: well, certainly something isn't right, but I have exhausted my own troubleshooting capabilities on this, which is why I have come here.

What specific information do you need from me to be able to spot what I am missing?

Thank you.

Here are my config settings:

# Virtual Hosts
#
<VirtualHost *:80>
ServerName localhost
ServerAlias localhost
DocumentRoot "${INSTALL_DIR}/www"
<Directory "${INSTALL_DIR}/www/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>


#
<VirtualHost *:80>
ServerName springboardqms.local #I've tried this with and without the suffix
DocumentRoot "c:/wamp64/www/springboardqms"
<Directory "c:/wamp64/www/springboardqms/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
</Directory>
</VirtualHost>

# Access example.dev from phone for testing
<VirtualHost *:8000>
ServerName springboardqms.local #I've tried this with and without the suffix
DocumentRoot "c:/wamp64/www/springboardqms"
<Directory "c:/wamp64/www/springboardqms/">
Options +Indexes +Includes +FollowSymLinks +MultiViews
AllowOverride All
Require local
# assuming yoursubnet is 192.168.0.?
# allow any ip on your WIFI access
Require ip 192.168.0
</Directory>
</VirtualHost>



Edited 1 time(s). Last edit at 01/02/2019 12:53PM by AliGW.

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 01:34PM

Do the error messages here help at all? Really getting desperate here - nothing I try is working.

springboardqms:8000 - Not a Listen port
Error(s) See below

Port :8000 used for the VirtualHost is not an Apache define variable
The path ${INSTALL_DIR}/www for DocumentRoot does not exist (File c:/wamp64/bin/apache/apache2.4.35/conf/extra/httpd-vhosts.conf)
The path ${INSTALL_DIR}/www/ for <Directory ... does not exist (File c:/wamp64/bin/apache/apache2.4.35/conf/extra/httpd-vhosts.conf)



Edited 1 time(s). Last edit at 01/02/2019 01:34PM by AliGW.

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: RiggsFolly (Moderator)
Date: January 02, 2019 01:47PM

Hi,

You should not need to port forward the router, if you are just trying to access the site from another device inside your local network.

Can I check how you are attempting to access the site from the other device.
Assuming that WAMPServer is running on IP address 192.168.0.100 then you would put this in the address bar of your other device


192.168.0.100:8000

and this should access your site

EDIT/UPDATE

I also assume you told Apache to listen on port 8000?

If not do this

wampmanager->tools->Add a listen port to Apache

And put 8000 in the dialog box that this will present you with

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.7 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-



Edited 1 time(s). Last edit at 01/02/2019 01:50PM by RiggsFolly.

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: Otomatic (Moderator)
Date: January 02, 2019 01:56PM

Hi,

> <VirtualHost *:8000>
Why port 8000 ?

Have you added port 8000 as a listening port for Apache?
If you want to use port 8000, you must - at least - tell Apache that you have to listen on this port.

And to do this correctly, you must use the tools integrated into Wampserver.

Right-Click -> Tools -> Add a listen port for Apache then choose 8000

Then, for VirtualHost for which you want to use port 8000, you should not put 8000 directly as port, but use the Apache variable created for this purpose:
Define MYPORT8000 8000

So, your VirtualHost must use this variable as if it had been created by Wampserver, so:
Not <VirtualHost *:8000>
but <VirtualHost *:${MYPORT8000}>

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 02:00PM

Thank you for your help[!

Yes to all of the above.

The laptop on which I have installed the WAMP Server has an IP address of 192.168.0.81, and I have tried this with a suffix of :80 and of :8000 - in both cases, I get the message saying that the server has stopped responding.

I have removed the port forwarding on the router and it has made no difference.

I have checked that the listening port is set up (8000).

I am able to access my development site through the browser on the laptop itself - no problem here.

I am still getting the error messages I posted above on the localhost page in the browser (I have restarted the services).

What else do I need to check?

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 02:03PM

> <VirtualHost *:8000>
Why port 8000 ?

Well, because that's what it said in the instructions to which I was directed in the first response in this thread. Should I change it back to 80?

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: Otomatic (Moderator)
Date: January 02, 2019 02:11PM

> Well, because that's what it said in the instructions to which I was directed in the first response in this thread. > Should I change it back to 80?

No. But, to use port 8000, do as I explained in my previous message.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.7 32 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25 - MariaDB 10.3.13
Wampserver 3.1.7 64 bit - Apache 2.4.38 - PHP 7.3.2/7.2.15/7.1.26/7.0.33/5.6.40 - MySQL 5.7.25/8.0.14 - MariaDB 10.3.13
PhPMyadmin 4.8.5 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 02:11PM

OK, so I have removed the reference to port 8000 and changed it back to 80. I tried to delete the listening port 8000 via Tools in Wamp Server, but it seems stuck on the list - no matter, the port 8000 error message has now gone. I am still unable to access the development site via any mobile device (iPhone or iPad).

Thank you both for your continued help.

EDIT: Have now got rid of the reference to port 8000 by deleting the two listening lines from the httpd.conf file that had been added. Nothing is now referring to port 8000 and all the error messages have gone from the localhost page in the browser.



Edited 3 time(s). Last edit at 01/02/2019 02:16PM by AliGW.

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 02:36PM

Something else that I should add is that I can instantly access the Sky router when I enter its IP address into the Safari browser on the iPad, so it's not that I cannot access the router.

I have also checked that my AV's firewall is allowing access to the Apache server, and it is.

Running out of ideas here.

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 03:47PM

I am making some progress! I found a setting hidden away in my AV and turned it on for HTTP access, and it has allowed access. Now I am faced with this message:

Forbidden
You don't have permission to access / on this server.

I must be getting close now - can anybody advise what the last step will be to allow me to see my development site?

Thanks!

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: RiggsFolly (Moderator)
Date: January 02, 2019 03:59PM

Check the

Require ip 192.168.0

Line in your httpd-vhosts.conf file. Make sure you are actually on the subnet.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.7 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Accessing Wamp Server from iPad
Posted by: AliGW (---.skybroadband.com)
Date: January 02, 2019 04:05PM

I added that line to the localhost section of the conf file and finally, it's working. Thank you very much indeed!!!

Options: ReplyQuote


Sorry, only registered users may post in this forum.