MySQL error after running for a day or so :-(
Posted by: LeMarque (---.cybermesa.com)
Date: December 17, 2018 10:20PM

Win10 1803 64bit
WAMP 3.1.6 32 bit
Apache 2.4.3.5
PHP 7.2.10 (For CLI 5.6.38)
MySQL 5.7.23
MariaDB 10.3.9
Icon is Green

Installed in C:\wamp

127.0.0.1 localhost

127.0.0.1 seventhwave

127.0.0.1 shopy

127.0.0.1 clicks

127.0.0.1 cheat

127.0.0.1 fuse

127.0.0.1 elewp

127.0.0.1 welewp

::1 localhost

I have spent hours and tried every suggestion on the board and am at my wits end.

Was using the 64bit version of WAMP and experienced the same as below. I completely removed it and installed the 32bit version of WAMP.

After a clean install, WAMP works to create a virtual host and I install WordPress. It works for a day and the I receive the following error in the WAMP server home page when I try to launch phpmyadmin:

phpMyAdmin - Error
The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.

I receive the followin when I try and launch WordPress

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in F:\elewp\wp-includes\wp-db.php:1564 Stack trace: #0 F:\elewp\wp-includes\wp-db.php(592): wpdb->db_connect() #1 F:\elewp\wp-includes\load.php(409): wpdb->__construct('root', '', 'elewp', 'localhost') #2 F:\elewp\wp-settings.php(106): require_wp_db() #3 F:\elewp\wp-config.php(89): require_once('F:\\elewp\\wp-set...') #4 F:\elewp\wp-load.php(37): require_once('F:\\elewp\\wp-con...') #5 F:\elewp\wp-blog-header.php(13): require_once('F:\\elewp\\wp-loa...') #6 F:\elewp\index.php(17): require('F:\\elewp\\wp-blo...') #7 {main} thrown in F:\elewp\wp-includes\wp-db.php on line 1564

The only change I made was to php.ini in C:\wamp\bin\apache\apache2.4.35\bin\php.ini

to increase the file upload size.

Went thru ALL the trouble shooting tips and found the page that listed all the MS required downloads and the direcr download for the 32bit version.

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: RiggsFolly (Moderator)
Date: December 17, 2018 11:07PM

Hi,

The `mysql_` extension was removed FOREVER from PHP 7.0.
So if you are using PHP7.2 that would explain the WordPress error

I am not a wordpress expert, but I am sure that WP can be configured to use the mysqli api, and has been able to for many years.

Or are you using a very old version of Wordpress?

Ifyou are then set WAMPServer to use PHP5.6 with Apache

wampmanager-> PHP-> Version -> PHP5.6.38

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.8 32bit & 64bit)
<Apache versions MULTIPE> <PHP versions MULTIPLE> <MySQL Versions MULTIPLE>
<MariaDB versions MULTIPLE> <phpMyAdmin versions MULTIPLE> <MySQL Workbench 8.0.16>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: LeMarque (---.cybermesa.com)
Date: December 18, 2018 12:19AM

Thank You Thank You!

That seemed to fix ALL the problems <fingers crossed>

That being phpmyadmin now loads. I'll install WP later.

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: LeMarque (---.cybermesa.com)
Date: December 18, 2018 06:42AM

Update -

Ran fine once installed WP, tried to upload a plugin, got a error about file size and the WAMP stopped working.

phpMyAdmin - Error
The mysqli extension is missing. Please check your PHP configuration. See our documentation for more information.



Edited 1 time(s). Last edit at 12/18/2018 06:44AM by LeMarque.

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: Otomatic (Moderator)
Date: December 18, 2018 09:17AM

Hi,

> Ran fine once installed WP, tried to upload a plugin, got a error about file size
This is a fatal error due to Wordpress and in no way a Wampserver error.

When you want to use tricks and things, you have to learn how to use them, it's not innate or intuitive.
PHP parameters can be modified by
Left-click -> PHP -> PHP -> PHP settings

> The mysqli extension is missing.
The mysqli PHP extension is validated on all PHP versions for Wampserver from PHP 5.3.0 to PHP 7.3.0.

Is mysqli seen in 'http://localhost/' page, in Loaded Extensions :

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.7/7.2.20/7.1.30/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.7/7.2.20/7.1.30/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 2 time(s). Last edit at 12/18/2018 01:30PM by Otomatic.

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: LeMarque (---.cybermesa.com)
Date: December 18, 2018 02:36PM

Thanks once again.

"Left-click -> PHP -> PHP -> PHP settings" That shows something about 'commented directives. Tried that but

I see PHP > PHP settings > phpinfo which I edited but still shows max size of 2M

"Is mysqli seen in 'http://localhost/' page, in Loaded Extensions :"

I see - mysqlnd

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: Otomatic (Moderator)
Date: December 18, 2018 03:37PM

Hi,

> "Left-click -> PHP -> PHP -> PHP settings" That shows something about 'commented directives.

What is this one?
You don't see upload_max_filesize whose value you can change to put up to 256M and even more!

> "Is mysqli seen in 'http://localhost/' page, in Loaded Extensions :" I see - mysqlnd


------------------------------------------------------------------------------------------------------------
Wampserver 3.1.9 32 bit - Apache 2.4.39 - PHP 7.3.7/7.2.20/7.1.30/7.0.33/5.6.40 - MySQL 5.7.26 - MariaDB 10.3.16
Wampserver 3.1.9 64 bit - Apache 2.4.39 - PHP 7.3.7/7.2.20/7.1.30/7.0.33/5.6.40 - MySQL 5.7.26/8.0.16 - MariaDB 10.3.16
PhPMyadmin 4.9.0.1 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: LeMarque (---.cybermesa.com)
Date: December 18, 2018 03:41PM

Update

I just reinstalled the 32bit version WITHOUT updating to 3.16 and clicking does show the php settings to

increase the upload size.

I'll see what happens

Options: ReplyQuote
Re: MySQL error after running for a day or so :-(
Posted by: LeMarque (---.cybermesa.com)
Date: December 18, 2018 04:05PM

I see it now. My best guess is that installing the update to 3.16 doesn't work on my system.

So far 3.1.4 works

Options: ReplyQuote


Sorry, only registered users may post in this forum.