Pages: 123Next
Current Page: 1 of 3
correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: November 28, 2018 03:34PM

1 windows 10 64 bit
2 wamp3.1.0 64 bit
3 apache 2.4.27
4 php 7.1.9
5 mysql 5.7.19
5a mariadb 10.2.8
Icon is green
I can run all virtual hosts
for the wamp tutorial for ssl hosts I made these virt hosts

127.0.0.1 *.wamphelpers.dev
::1 *.wamphelpers.dev

127.0.0.1 *.wamphelpers.localhost
::1 *.wamphelpers.localhost

locahost is achievable
I have access to PHPMyAdmin
I use AVAST as antivir
A:\wamp64\ is my wamp location
I am following this tutorial for creating aan SSL and https connection because I cant use firefox since some time as they oblige a https connection for all url’s

tut: [forum.wampserver.com]
I have openssl.exe in the right dir installed

My problem starts just before step 2 begins.
When generating the pem file I do it this way
.\openssl genrsa –out website\server.key 2048
When I dont use .\ windows doesnt trust the openssl command.
In the \website\ dir I didnt find a file with a *.pem extension but this file: server.key
then I replaced the command server.key to privkey.pem. Is that allowed?

Then I continued but got an error
This is a copypaste of my PowerShell

PS A:\wamp64\bin\apache\apache2.4.27\bin\website> cd \wamp64\bin\apache\apache2.4.27\bin\

PS A:\wamp64\bin\apache\apache2.4.27\bin> .\openssl req -new -key website\privkey.pem -out website\server.csr

Can't open C:\Program Files\Common Files\SSL/openssl.cnf for reading, No such file or directory

5948:error:02001003:system library:fopen:No such process:crypto\bio\bss_file.c:74:fopen('C:\Program Files\Common Files\SSL/openssl.cnf','r')


5948:error:2006D080:BIO routines:BIO_new_file:no such file:crypto\bio\bss_file.c:81:

unable to find 'distinguished_name' in config
problems making Certificate Request
5948:error:0E06D06A:configuration file routines:NCONF_get_string:no conf or environment variable:crypto\conf\conf_lib.c:272:

PS A:\wamp64\bin\apache\apache2.4.27\bin> .\openssl req -new -key website\server.key -out website\server.csr

Can't open C:\Program Files\Common Files\SSL/openssl.cnf for reading, No such file or directory
11088:error:02001003:system library:fopen:No such process:crypto\bio\bss_file.c:74:fopen('C:\Program Files\Common Files\SSL/openssl.cnf','r')
11088:error:2006D080:BIO routines:BIO_new_file:no such file:crypto\bio\bss_file.c:81:
unable to find 'distinguished_name' in config
problems making Certificate Request
11088:error:0E06D06A:configuration file routines:NCONF_get_string:no conf or environment variable:crypto\conf\conf_lib.c:272:
PS A:\wamp64\bin\apache\apache2.4.27\bin>

regarding the error message
I checked the phpinfo() file here I found the following location for openssl.conf :
c:/usr/local/ssl/openssl.cnf
though this is not really a dir location on my c-disk and also not on my A: volume

How to solve this problem? I really want a SSL connection for my virtual hosts so please help



Edited 2 time(s). Last edit at 11/30/2018 07:44AM by LivingThis.

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: November 29, 2018 12:50PM

I found the location, but when using openssl commands it should be found in the correct way.

the location is : A:\wamp64\bin\php\php7.1.9\extras\ssl\openssl.cnf

What causes the wrong settings?



Edited 2 time(s). Last edit at 11/30/2018 07:44AM by LivingThis.

Options: ReplyQuote
Re: correct location of openssl.conf
Posted by: Otomatic (Moderator)
Date: November 29, 2018 02:01PM

Hi,

As in all Apache versions, even Apache 2.4.27, openssl.exe is where it has always been, that is:
wamp64\bin\apache\apache2.4.27\bin\openssl.exe

just as openssl.cnf is always in the same place regardless of the Apache version, i. e. :
wamp64\bin\apache\apache2.4.27\conf\openssl.cnf

As well as there is also, since PHP 5.4, wamp64\bin\php\phpx.y.z\extras\ssl\openssl.cnf

There are no " wrong settings " The files mentioned have always been where they are.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 11/29/2018 06:10PM by Otomatic.

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: November 30, 2018 08:20AM

I got that Otomatic. But back to the tutorial.

Right before step 2 it uses openssl genrsa –out website\server.key 2048 and in my dir /website/ a file called server.key is placed, but from there the tutorial assumes I have a file called privkey.pem. I can't find this pem file.

Should it be generated due to the command or should I replace server.key with the privkey.pem?

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: November 30, 2018 09:06AM

Hi,

> But back to the tutorial.
OK -> Open up a Command window (Dos box) using Run as Administrator

A "command window" is not a Powershell window.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: November 30, 2018 11:26AM

I pressed cmd en right mouseclick run as administrator.

Because the execution of
openssl genrsa -out website\server.key 2048
did not lead to a file called privkey.pem
I made this myself.
is that okay ?

This is the copypaste of the command line window.


++++++++++++++++++++++++++++++++++++++++++


A:\wamp64\bin\apache\apache2.4.27\bin>openssl genrsa -out website\server.key 2048
Generating RSA private key, 2048 bit long modulus
......................................+++
....................................................................+++
e is 65537 (0x010001)

A:\wamp64\bin\apache\apache2.4.27\bin>openssl genrsa -out website\privkey.pem 2048
Generating RSA private key, 2048 bit long modulus
.....................................................+++
........................+++
e is 65537 (0x010001)

A:\wamp64\bin\apache\apache2.4.27\bin>openssl req -new -key website\server.key -out website\server.csr

Can't open C:\Program Files\Common Files\SSL/openssl.cnf for reading, No such file or directory
7728:error:02001003:system library:fopen:No such process:crypto\bio\bss_file.c:74:fopen('C:\Program Files\Common Files\SSL/openssl.cnf','r')
7728:error:2006D080:BIO routines:BIO_new_file:no such file:crypto\bio\bss_file.c:81:
unable to find 'distinguished_name' in config
problems making Certificate Request
7728:error:0E06D06A:configuration file routines:NCONF_get_string:no conf or environment variable:crypto\conf\conf_lib.c:272:

A:\wamp64\bin\apache\apache2.4.27\bin>

+++++++++++++++++++++++++++++++++++++++++++

So it gives an error messages saying it cant find openssl.cnf

What is the proper location that openssl should be searching in?

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: November 30, 2018 01:38PM

Hi,

> did not lead to a file called privkey.pem - I made this myself. is that okay ?
I think it's a writing error, you don't have to create this file or rename it.

> Can't open C:\Program Files\Common Files\SSL/openssl.cnf for reading, No such file or directory
Did you send the command :
set openssl_conf=c:\wamp\bin\apache\{apache_version}\conf\openssl.cnf

There is no problem with my Apache :
j:\wamp\bin\apache\apache2.4.37\bin>set openssl_conf=j:\wamp\bin\apache\apache2.4.37\conf\openssl.cnf
j:\wamp\bin\apache\apache2.4.37\bin>md website
j:\wamp\bin\apache\apache2.4.37\bin>openssl genrsa -out website\server.key 2048
Generating RSA private key, 2048 bit long modulus (2 primes)
................+++++
.......................................+++++
e is 65537 (0x010001)

j:\wamp\bin\apache\apache2.4.37\bin>openssl req -new -key website\server.key -out website\server.csr
You are about to be asked to enter information that will be incorporated
into your certificate request.
What you are about to enter is what is called a Distinguished Name or a DN.
There are quite a few fields but you can leave some blank
For some fields there will be a default value,
If you enter '.', the field will be left blank.
-----
Country Name (2 letter code) [AU]:FR
State or Province Name (full name) [Some-State]: Paris
Locality Name (eg, city) []: Paris
Organization Name (eg, company) [Internet Widgits Pty Ltd]:Otomatic
Organizational Unit Name (eg, section) []:WebServer
Common Name (e.g. server FQDN or YOUR name) []:local.aviatechno.net
Email Address []:wampserver@otomatic.net

Please enter the following 'extra' attributes
to be sent with your certificate request
A challenge password []:
An optional company name []:

j:\wamp\bin\apache\apache2.4.37\bin>

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: December 02, 2018 01:53PM

I changed all directives as recommended in the tut.

I restarted wamp and the icon is orange.

In the command window I did: httpd -t
output: Syntax OK.

Then I did TOOLS (right mouse click on wamp icon) and Check State of Services and it said
The service 'wampapache64' is NOT started

Could it be I have to change port settings to 443 to make sure its a secure request.

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: December 02, 2018 06:26PM

Hi,

> Could it be I have to change port settings to 443 to make sure its a secure request.
No.

This tutorial (which is a little dated) was originally for Apache 2.2.
With Apache 2.4 you need to make some changes, but it works.

Here is an example of the httpd-ssl.conf file that works with Apache 2.4 in my PC, but that you will need to adapt to your configuration
#
# This is the Apache server configuration file providing SSL support.
# It contains the configuration directives to instruct the server how to
# serve pages over an https connection. For detailed information about these
# directives see <URL:[httpd.apache.org];

# Required modules: mod_log_config, mod_setenvif, mod_ssl,
#          socache_shmcb_module (for default value of SSLSessionCache)

Listen 0.0.0.0:443 https
Listen [::0]:443 https

#   SSL Cipher Suite:
SSLCipherSuite HIGH:MEDIUM:!MD5:!RC4:!3DES
SSLProxyCipherSuite HIGH:MEDIUM:!MD5:!RC4:!3DES
SSLHonorCipherOrder on

#   SSL Protocol support:
SSLProtocol all -SSLv3
SSLProxyProtocol all -SSLv3

#   Pass Phrase Dialog:
SSLPassPhraseDialog  builtin

SSLSessionCache        "shmcb:${INSTALL_DIR}/logs/ssl_scache(512000)"
SSLSessionCacheTimeout  300

##
## SSL Virtual Host Context
##

<VirtualHost *:443>
	ServerName aviatechno
  DocumentRoot "G:/www/aviatechno"
  ServerAdmin webmaster@aviatechno.net
	ErrorLog "${INSTALL_DIR}/logs/error.log"
	TransferLog "${INSTALL_DIR}/logs/access.log"
	SSLEngine on
	SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
	SSLCertificateFile      "${SRVROOT}/conf/Certificats/aviatechno.crt"
	SSLCertificateKeyFile   "${SRVROOT}/conf/Certificats/aviatechno.key"
	SSLCACertificateFile    "${SRVROOT}/conf/Certificats/Cacerts/ca.crt"
#
	SSLVerifyClient none
	SSLVerifyDepth  10

	<Directory "G:/www/aviatechno/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride all
		Require local
	</Directory>
	<FilesMatch "\.(cgi|shtml|phtml|php)$">
		SSLOptions +StdEnvVars
	</FilesMatch>

	BrowserMatch "MSIE [2-5]" nokeepalive ssl-unclean-shutdown downgrade-1.0 force-response-1.0
	CustomLog "${INSTALL_DIR}/logs/custom.log" "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: December 03, 2018 11:37AM

Hi,

I'm thinking of rewriting a procedure to enable SSL (https) on a local site defined as VirtualHost, only with the tools available under Windows and Apache, i. e. the command line (cmd.exe) and openssl.exe in apachex.y.z/bin

This requires a lot of checking and, of course, since it will be a self-signed certificate, there will be the usual warnings from the different browsers that you will have to override manually by adding an exception.
But... don't be in too much of a hurry...

And, last but not least, it will only be to develop locally and see the behavior of a local site in https, in no way to open the site to the outside world.

Another remark, it may not be the easiest procedure to follow, but it will have the advantage of being functional and can be applied (in part) several times for different local sites.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »



Edited 1 time(s). Last edit at 12/03/2018 11:41AM by Otomatic.

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: December 04, 2018 09:58AM

In the windows logbook I found 4 errors:

error 1:

The Apache service named // reported the following error: >>> (OS 10048) Each socket address (protocol / networdk address / port ) can be used only once normally : AH00072: make_sock: could not bind to address [::]:443

error 2 is the same

error 3:
The Apache service named // reported the following error: >>> AH00451: no listening sockets available, shutting down

error 4: The Apache service named // reported the following error: >>> AH00015: Unable to open logs

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: RiggsFolly (Moderator)
Date: December 04, 2018 10:11AM

Hi,

This sounds like you have something else that is using port 443.

Are you running some other software that could have assigned port 443? Have you uninstalled or disabled IIS for example.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: December 04, 2018 11:17AM

Not sure. It could be skype. But the latest skype client doesnt have an option to change the port skype uses.

I did netstat -anob | findstr :443 and tasklist /fi "pid eq {pid}"

the output was that I had these services running:

SkypeApp.exe
WinStore.App.exe
Dropbox.exe
Video.UI.exe
svchost.exe

This are a lot of services. I'm not sure what to do. Should I remove these services, if that is possible or should I change the settings to another port, what is recommended?



Edited 1 time(s). Last edit at 12/04/2018 11:31AM by LivingThis.

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: RiggsFolly (Moderator)
Date: December 04, 2018 11:43AM

Ok first try closing SKYPE.
The start WAMPServer
Does it all work when you do this?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: December 05, 2018 09:46AM

I removed skype.

I shut off dropbox.

I have now 2 processes reporting they use port 443.

1) svchost.exe
2) SearchUI.exe

The icon is still orange

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: December 05, 2018 12:02PM

Hi,

It is possible to add an option to test port 443, as well as to test port 80.
With Wampserver started, adding this option can be done.
With for example Notepad+++ (Not notepad.exe from Windows) open the file wamp(64)/wampmanager.tpl
Search for ;WAMPPHPCLIMENUSTART
six lines down, there's the line:
Type: item; Caption: "${w_testPort80}"; Action: run; FileName: "${c_phpExe}"; Parameters: "testPort.php 80 ${c_apacheService}";WorkingDir: "$c_installDir/scripts"; Flags: waituntilterminated; Glyph: 24
Duplicate this line to add it below and modify the new line to get the following two lines by add 443 then and replace 80 by 443:
Type: item; Caption: "${w_testPort80}"; Action: run; FileName: "${c_phpExe}"; Parameters: "testPort.php 80 ${c_apacheService}";WorkingDir: "$c_installDir/scripts"; Flags: waituntilterminated; Glyph: 24
Type: item; Caption: "${w_testPort80} 443"; Action: run; FileName: "${c_phpExe}"; Parameters: "testPort.php 443 ${c_apacheService}";WorkingDir: "$c_installDir/scripts"; Flags: waituntilterminated; Glyph: 24
Save the modified file.
To create this new option, just refresh Wampmanager, so:
Right-Click -> Refresh

There is a new tools :
Right-Click -> Tools -> Test port 80 443
It is always marked "Test port 80" before 443 because it would have been more complicated to create language variables as well.

When I do this on my Wampserver which uses port 443 and SSL (Under development), I get the following result:
***** Test which uses port 443 *****
===== Tested by command netstat filtered on port 443 =====
Test for TCP
Your port 443 is used by a processus with PID = 2764
The processus of PID 2764 is 'httpd.exe' Session: Services
The service of PID 2764 for 'httpd.exe' is 'wampapache'
This service is from Wampserver - It is correct

Test for TCPv6
Your port 443 is used by a processus with PID = 2764
The processus of PID 2764 is 'httpd.exe' Session: Services
The service of PID 2764 for 'httpd.exe' is 'wampapache'
This service is from Wampserver - It is correct

===== Tested by attempting to open a socket on port 443 =====
Your port 443 is actually used by :
Server: Apache/2.4.37 (Win32) OpenSSL/1.1.1a PHP/7.2.12

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: December 05, 2018 02:35PM

I checked the tpl file but could not find: ;WAMPPHPCLIMENUSTART

But in the tools menu I did find port test options.


I have the option ----> use a port other then 80.

output for 443:

The port number you give: 443

is not valid or already used or is default port




There is also an option --------> add a listen port for apache

output for 443

The port number you give: 443

is not valid

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: December 05, 2018 03:00PM

Hi,

> I checked the tpl file but could not find: ;WAMPPHPCLIMENUSTART
Update your 3.1.0 version to 3.1.6

- Verify that all VC ++ packages are installed and with the latest versions.
To do this, use the tool:
Checks VC++ packages installed
Do not use a previously loaded tool. Make a new download to make sure you are using the correct version.
To download missing packages, do not rely on Microsoft links, they are not reliable, download packages on http://wampserver.aviatechno.net in section Visual C++ Redistribuable Packages
Do not forget that if you have a 64 bit Windows, you must install both 32 and 64 bit versions of each package.
You must install each package "as an administrator", so right-click the exe file and then run as Administrator.

- Apply Update 3.1.6 to your version of Wampserver
Wampserver update 3.1.6

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: LivingThis (---.cm-6-4a.dynamic.ziggo.nl)
Date: December 10, 2018 10:23AM

I installed the updates and packages and checked the dependencies again and this is all okay.

When I start WAMP the icon is orange.

PHP is not working and the other 2 have started.

In the wamp menu, when clicking left mouseclick I see a message saying:

Error A:/wamp64 or PHP in PATH

clicking on this error gives a command line console message saying:


.....................................................................


Sorry,

There is an error.

There is Wampserver path (A:/wamp64)
into Windows PATH environnement variable: (A:\wamp64\bin\php\php7.1.9)

It seems that a PHP installation is declared in the environment variable PATH
A:\wamp64\bin\php\php7.1.9

Wampserver does not use, modify or require the PATH environment variable.
Using a PATH on Wampserver or PHP version
is detrimental to the proper functioning of Wampserver.

...................................................

What to do to solve this error?

Options: ReplyQuote
Re: correct location of openssl.cnf
Posted by: Otomatic (Moderator)
Date: December 10, 2018 10:27AM

Hi,

Suppress 'A:\wamp64\bin\php\php7.1.9' from the PATH environment variable.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Pages: 123Next
Current Page: 1 of 3


Sorry, you can't reply to this topic. It has been closed.