localhost WampServer home page warnings and errors
Posted by: JanetW (217.146.29.---)
Date: November 07, 2018 12:19AM

I'm asking for your help not only because of the errors on the localhost WampServer home page (see below), but also because in the Your Projects section there is a warning notice.

Further, from Your Projects, all project links lead to either the front page for the project concerned or to a directory list, except one - xyz. This returns
Not Found
The requested URL /xyz/xxyz.htm was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.4.33 (Win64) PHP/7.1.16 Server at localhost Port 80

Firstly, I can go to all pages of the project xyz via [localserver] with no problems.
Secondly, the root/home page for xyz is /index.htm, not /xyz/xxyz.htm. That is a page in a subsidary folder to the site root.

Please would you advise me as to what I have done wrong and how to correct the various problems?

(Please be aware that the WampServer installation was done by someone knowledgeable Of WAMP who is no longer available. I am relying on trying to understand and follow advice etc from WampServer help pages and elsewhere on the net.)
***

Windows 10 64-bit
Wampserver 3.1.3 64-bit
Apache 2.4.33
PHP 7.1.16
MySQL 5.7.21
MariaDB 10.2.14

HOSTS active lines:
	127.0.0.1 localhost
	127.0.0.1 localserver
	127.0.0.1 frontpage
	127.0.0.1 joomla-xy joomla.localhost

	::1 localhost
	::1 localserver
	::1 frontpage
	::1 joomla-xy joomla.localhost

WAMP icon is green.

I have access to localhost.
localhost (Homepage WampServer) error message:
[in red, error] Port :8083 used for the VirtualHost is not an Apache define variable

[in blue, warning] It's a bad idea to add localhost in the url of launching
projects. It is best to define VirtualHost in
wamp/bin/apache/apache2.4.33/conf/extra/httpd-vhosts.conf
file and not add localhost in the url.

I can access PHPMyAdmin.

Antivirus: F-Secure SAFE.
Firewall: Windows Defender

Installation full path: c:/wamp64

Virtual Hosts:
Below is the contents of httpd-vhosts.conf.
	<VirtualHost *:80>
	  ServerName localhost
	  ServerAlias localhost
	  DocumentRoot "${INSTALL_DIR}/www"
	  <Directory "${INSTALL_DIR}/www/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	  </Directory>
	</VirtualHost>

	<VirtualHost *:8083>
	  ServerName localhost
	  ServerAlias localhost
	  DocumentRoot "${INSTALL_DIR}/www/xyz"
	  <Directory "${INSTALL_DIR}/www/xyz">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
		Require ip 192.168.1
	  </Directory>
	</VirtualHost>

	<VirtualHost *:8084>
	  ServerName localhost
	  ServerAlias localhost
	  DocumentRoot "${INSTALL_DIR}/www/zyx"
	  <Directory "${INSTALL_DIR}/www/zyx">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
		Require ip 192.168.1
	  </Directory>
	</VirtualHost>

	<VirtualHost *:8085>
	  ServerName localhost
	  ServerAlias localhost
	  DocumentRoot "${INSTALL_DIR}/www/frontpage"
	  <Directory "${INSTALL_DIR}/www/frontpage">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
		Require ip 192.168.1
	  </Directory>
	</VirtualHost>

	<VirtualHost *:8086>
	  ServerName localhost
	  ServerAlias localhost
	  DocumentRoot "${INSTALL_DIR}/www/joomla-xy"
	  <Directory "${INSTALL_DIR}/www/joomla-xy">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
		Require ip 192.168.1
	  </Directory>
	</VirtualHost>
also, from the WampServer localhost page:
Your VirtualHost
localhost
localhost:8083 - Not a Listen port
localhost:8084 - Not a Listen port
localhost:8085 - Not a Listen port
localhost:8086 - Not a Listen port
Error(s) See below



Edited 1 time(s). Last edit at 11/07/2018 10:01AM by RiggsFolly.

Options: ReplyQuote
Re: localhost WampServer home page warnings and errors
Posted by: RiggsFolly (Moderator)
Date: November 07, 2018 10:05AM

Did you also amend the httpd.conf and add Listen directives for these other port numbers

#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, instead of the default. See also the <VirtualHost>
# directive.
#
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
#Listen 12.34.56.78:80
Listen 0.0.0.0:80
Listen [::0]:80
# Additional port numbers to listen on
Listen 0.0.0.0:8083
Listen 0.0.0.0:8084
Listen 0.0.0.0:8085
Listen 0.0.0.0:8086
Listen [::0]:8083
Listen [::0]:8084
Listen [::0]:8085
Listen [::0]:8086

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: localhost WampServer home page warnings and errors
Posted by: Otomatic (Moderator)
Date: November 07, 2018 01:30PM

Hi,

For this to work correctly, you must add the additional listening ports through the Wampserver Tool menu:

Right-Click -> Tools -> Add a listyen port to Apache

For this to work correctly, you must add the additional listening ports through the Wampserver Tool menu:
And you must create your VirtualHost from the Add a VirtualHost page of Wampserver.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: localhost WampServer home page warnings and errors
Posted by: JanetW (217.146.29.---)
Date: November 11, 2018 12:33AM

Dear RiggsFolly

Whoops, sorry that I hadn't made that clear - yes, httpd.conf had the code
#Listen 12.34.56.78:80
Listen 0.0.0.0:80
Listen [::0]:80
Listen 0.0.0.0:8081
Listen [::0]:8081
Listen 0.0.0.0:8082
Listen [::0]:8082
Listen 0.0.0.0:8083
Listen [::0]:8083
Listen 0.0.0.0:8084
Listen [::0]:8084
Listen 0.0.0.0:8085
Listen [::0]:8085
Listen 0.0.0.0:8086
Listen [::0]:8086
in it.
What you have put is cleaner, so I have changed to that.
However, that change has not improved things.
I am currently communicating with Otomatic about the help he's suggested in his answer to me.
Thank you for your help
JW

Options: ReplyQuote
Re: localhost WampServer home page warnings and errors
Posted by: JanetW (217.146.29.---)
Date: November 11, 2018 12:43AM

Dear Otomatic
Thank you for your reply.
1) Regarding Add listen post - if I right click on Tools or the three items listed there, I get a standard browser's menu, nothing on Add listen post. The Tools list is as follows:
Tools
phpinfo()
phpmyadmin
Add a Virtual Host

2) Using Add a Virtual Host, I created a new Virtual Host for the project, xyz. After refreshing the WampServer localhost page, I still have the same result on clicking on the project link for xyz:
Not Found
The requested URL /xyz/xxyz.htm was not found on this server. etc.
Would you advise please?
Regards JW

Options: ReplyQuote
Re: localhost WampServer home page warnings and errors
Posted by: Otomatic (Moderator)
Date: November 11, 2018 09:19AM

Hi,

With Wampserver, you should not add "ListenPort" by hand directly in the httpd.conf file. You MUST use the Tools menu item "Add a listen port to Apache".

This is because additional listening ports are managed by Apache variables like this :
Define APACHE24 Apache2.4
Define VERSION_APACHE 2.4.37
Define INSTALL_DIR j:/wamp
Define APACHE_DIR ${INSTALL_DIR}/bin/apache/apache${VERSION_APACHE}
Define SRVROOT ${INSTALL_DIR}/bin/apache/apache${VERSION_APACHE}
Define MYPORT8082 8082
Define MYPORT8081 8081
then
#Listen 12.34.56.78:80
Listen 0.0.0.0:80
Listen [::0]:80
Listen 0.0.0.0:${MYPORT8082}
Listen [::0]:${MYPORT8082}
Listen 0.0.0.0:${MYPORT8081}

Similarly for VirtualHost, you must create them after adding additional listening ports to get, for example, a definition of VirtualHost like this:
#
<VirtualHost *:${MYPORT8081}>
	ServerName mysite
	DocumentRoot "j:/wamp/www/phpbb3"
	<Directory  "j:/wamp/www/phpbb3/">
		Options +Indexes +Includes +FollowSymLinks +MultiViews
		AllowOverride All
		Require local
	</Directory>
</VirtualHost>

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.11/7.1.23/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.