Executing .cgi files on Windows
Posted by: iantresman (---.bb.sky.com)
Date: October 29, 2018 01:56PM

My virtual host is not executing a .cgi files (a windows utility with an MZ header). When I click the file, my Browser want to Open it. In the C:\wamp64\bin\apache\apache2.4.35\conf\extra\httpd-vhosts.conf file, I have:

1. Added +ExecCGI to the line:
Options +Indexes +Includes +FollowSymLinks +MultiViews +ExecCGI

2. Added to the end of the file, the line:
AddHandler cgi-script .cgi

I've tried:
1. Restarting all services.
2. Tweaking the same line in C:\wamp64\bin\apache\apache2.4.35\conf\httpd.conf

Am running Windows10, Firefox. PHP is running fine. Anything more I can try?

Options: ReplyQuote
Re: Executing .cgi files on Windows
Posted by: Otomatic (Moderator)
Date: October 29, 2018 04:50PM

Hi,

I've never done it before, but I think it's best to check the Apache documentation:
Apache Tutorial: Dynamic Content with CGI

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.4 32 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
Wampserver 3.1.4 64 bit - Apache 2.4.37 - PHP 7.2.12/7.1.24/7.0.32/5.6.38 - MySQL 5.7.23 - MariaDB 10.3.10
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote


Sorry, only registered users may post in this forum.