Can no longer connect to my virtual host
Posted by: DJMarvin54 (---.fuse.net)
Date: October 09, 2018 06:11AM

I am relatively new to WAMPServer but followed all the steps in sequence to create a virtual host and install WordPress. Everything worked fine and I enjoyed several hours of playing with WP and setting up a development website.
Today, I logged onto my PC, started WAMPServer, and went to my virtual host and received this message - ERR_CONNECTION_REFUSED.
I tried reading through forum posts to see if I could find something that would help but nothing I found seemed to relate to my issue. I do have information in my various log files but little of it makes any sense to me.
I also went into Norton and added all the various files that could be blocked as part of its protection.
I am sitting here feeling totally lost. I spent several hours working in my site yesterday and today I can't do a thing. I haven't changed anything else on my system.I don't have Skype so that isn't a problem,

So - in a nutshell - help. :-)

Options: ReplyQuote
Re: Can no longer connect to my virtual host
Posted by: RiggsFolly (Moderator)
Date: October 09, 2018 09:52AM

Hi,

The first thing we need to be able to help you is to see the answers to all these questions
READ (and answer) BEFORE YOU ASK A QUESTION

First thing to check is always to see if Apache and your database service (MySQL or mariaDcool smiley have started.

Second would be to check the error logs

1. look at Apache error log
- wampmanager->Apache->Apache Error log
- wampmanager->MySQL->MySQL log
- wampmanager->mariaDB->mariaDB log

- also look at the Windows Event Viewer for error messages from Apache or MySQL etc

Let us know what you find.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Can no longer connect to my virtual host
Posted by: DJMarvin54 (---.fuse.net)
Date: October 09, 2018 03:04PM

My bad! I knew to check and include this information but guess I was too tired and frustrated and overlooked it.

1 - Windows version used (Specify version number AND whether 32 or 64 bit)
Windows 10 Pro 64-bit version 1803

2 - Version WampServer (Specify version number AND whether 32 or 64 bit)
WampServer Version 3.1.0 64bit

3 - Apache Version - 2.4.27

4 - PHP Version - 5.6.31

5 - MySQL Version - 5.7.19

5a - MariaDB version if applicable - Not using

6 - What color is the WampServer icon (in the notification area of the taskbar)
Green


All services are running

I think I know what's wrong. I did make a change and, after checking to confirm, this appears to be the issue.
When I installed WAMPserver, I accepted the default browser, Internet Explorer. IE has been giving me problems with a theme development application I am using so I decided to switch to Chrome. After researching how to do this, I edited the wampserver.conf to use Chrome. The file now reads:

;Path of the Browser used by Wampserver
;May be modfied with the absolute path of the browser exe file
;(Use / instead of \)
navigator ="C:/Program Files (x86)/Google/Chrome/Application/chrome.exe"
;Path of the Text Editor used by Wampserver
;May be modfied with the absolute path of the Text Editor exe file
;(Use / instead of \)
editor ="C:/Program Files (x86)/Notepad++/notepad++.exe"

If I change it back to IE, everything works fine (except my theme builder). Is there another file I have to change?

Options: ReplyQuote
Re: Can no longer connect to my virtual host
Posted by: RiggsFolly (Moderator)
Date: October 10, 2018 10:28AM

Hi,

Appears to be nothing wrong with your Chrome changes in wampmanager.conf.... BUT

Chrome is a bit odd about localhost and local web sites. ( al in an effort to pretect the innocent from themselves I believe)

Do a quick Google on "Chrome localhost" and check. The fixes for this change all the time so I wont even bother trying to record the current fix as it will likely be out of date in a month.

To check that Chrome is the issue, install FireFox, if you have not already, and then change wampmanager.conf to use FireFox.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote


Sorry, only registered users may post in this forum.