Pages: 12Next
Current Page: 1 of 2
Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 07, 2018 06:56PM

Hi, I use WAMP 2.4. Please, how can I upgrade individual parts (PHP, MySQL) separately? Due to Windows XP, I can not install a higher version of the entire wamp. Thanks in advance for your advice.

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: RiggsFolly (Moderator)
Date: October 07, 2018 08:48PM

Hi,

What versions do you want to upgrade PHP and MySQL to ?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 07, 2018 09:34PM

Hi,

I have PHP 5.4.16 and I need at least 5.6, or rather higher, (7. .....)

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: Otomatic (Moderator)
Date: October 08, 2018 09:47AM

Hi,

With Windows XP, PHP 5.5, 5.6 and PHP 7 are impossible, as are many other versions of MySQL.
Indeed, these versions are compiled with VC11 or VC14 or VC15 and the related redistributable VC++ packages are incompatible with XP.

In the PHP archives: [windows.php.net] VC11 is used from PHP 5.5.0 onwards, so it is impossible to install a PHP version equal to or greater than 5.5.0 on Windows XP.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 08, 2018 05:01PM

Hi,
****
Visual C++ Redistributable for Visual Studio 2015

Supported Operating System
Windows 10 , Windows 7 Service Pack 1, Windows 8, Windows 8.1, Windows Server 2003 Service Pack 2, Windows Server 2008 R2 SP1, Windows Server 2008 Service Pack 2, Windows Server 2012, Windows Vista Service Pack 2, Windows XP Service Pack 3
*****
I use Windows XP Service Pack3. So what's the problem?

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: Otomatic (Moderator)
Date: October 08, 2018 05:24PM

Hi,

Try to install VC11, VC13 packages: See item 20 of TROUBLESHOOTING TIPS

What is your Apache version ?

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 08, 2018 05:31PM

Hi,

Apache version 2.4.4, MySQL 5.6.12.

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: Otomatic (Moderator)
Date: October 08, 2018 06:16PM

Hi,

Please, put in your next answer, the first fifteen lines of your wampmanager.conf and wampmanager.ini files and I will compile an installer for a PHP addon 5.6.17 for Wampserver 2.4.

Nevertheless, even if the installer works well and installs a PHP version 5.6.17, I am very concerned that the internal scripts of Wampserver 2.4 are not designed to support PHP 5.6.x

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 08, 2018 08:56PM

wampmanager.ini

[Config]
;WAMPCONFIGSTART
ImageList=images_on.bmp
ServiceCheckInterval=1
ServiceGlyphRunning=13
ServiceGlyphPaused=14
ServiceGlyphStopped=15
TrayIconAllRunning=16
TrayIconSomeRunning=17
TrayIconNoneRunning=18
ID={wampserver}
AboutHeader=WAMPSERVER
AboutVersion=Version 2.4
;WAMPCONFIGEND

[AboutText]
WampServer Version 2.4

Created by Romain Bourdon (romain@romainbourdon.com)
Maintainer / Upgrade / RoadMap by Herve Leclerc (herve.leclerc@alterway.fr)

Sources are available at SourceForge

***
wampmanager.conf
[main]
language = "czech"
status = "online"
wampserverVersion = 2.4
wampserverLastKnown = 2.4
installDir = "c:/wamp"
navigator = "C:\Program Files\Opera\launcher.exe"
defaultLanguage = english


[php]
phpVersion = "5.4.16"
phpLastKnown = 5.4.16
phpIniDir = .
phpConfFile = php.ini
phpExeDir = .


[phpCli]
phpCliVersion = 5.4.16
phpExeFile = php.exe
phpCliFile = php-win.exe

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: Otomatic (Moderator)
Date: October 09, 2018 10:18AM

Hi,

There is installer addon PHP 5.6.17 for Wampserver 2.4 on Windows XP here :
http://wampserver.aviatechno.net/files/php/wampserver24_x86_addon_php5.6.17_xp.exe

Download this file then run it "as an administrator".
As this is Wampserver 2.4, the addon installer cannot automatically find the installation path, so in the form below, you will need to put "c:\wamp" as the installation path in place of "j:\wamp" that is my installation path:


After complete installation of the addon, you launch Wampserver 2.4 and you will see that PHP version 5.6.17 is in the PHP versions dialog:
Left-click Wampmanager icon -> PHP -> Version :


One click on version number 5.6.17 and there will be a change from PHP version to 5.6.17:


I can't guarantee that this will work on your Wampserver 2.4 version under Windows XP.
I really performed this procedure under Windows 7 Pro 64 bit with Wampserver 3.1.4 32 bit simulating a Wampserver 2.4.

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 10, 2018 02:39AM

Hi,
When wamp started to run (2x), PHP version 5.6.17 is in the PHP version dialog box. Now warnings appear and can not be removed even after the wamp has ended.
*************************************************
PHP Startup: imap:Unable to initialize module
Module compile with module API=2013226
PHP compiled with module API=20100525
These options need to match
* OK*
*************************************************
*************
PHP Startup
*OK*
*************

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: Otomatic (Moderator)
Date: October 10, 2018 09:22AM

Hi,

Incompatibility between the PHP compilation module and the one on your system or Apache's system.
Try reinstalling - as an administrator - the VC++s that are on [wampserver.aviatechno.net] section VC++

------------------------------------------------------------------------------------------------------------
Wampserver 3.1.6 32 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
Wampserver 3.1.6 64 bit - Apache 2.4.37 - PHP 7.3.0/7.2.13/7.1.25/7.0.33/5.6.39 - MySQL 5.7.23 - MariaDB 10.3.11
PhPMyadmin 4.8.3 - MysqlDumper 1.24.5
on W10 and W7 Pro 64 bit
Documentation Apache - Documentation PHP - Documentation MySQL - Wampserver install files & addons
« Ce n'est pas parce qu'ils sont nombreux à avoir tort, qu'ils ont forcément raison. Coluche »
« It's not because they are many to be wrong, they are necessarily right. Coluche »

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 10, 2018 10:03PM

Hello,

I've installed Microsoft Visual C ++ 2013 Redistributable (x86) - 12.0.40664 and nothing has changed.

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: RiggsFolly (Moderator)
Date: October 10, 2018 10:59PM

INSTALL ALL OF THEM Both 32 and 64 bit if you are using 64 bit WAMPServer. You only need the 32 bit ones if you are on a 32bit Windows.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 11, 2018 01:18AM

Hi,

I installed all VC++ x86 (I have 32 bit Windows).
Warning is the same, "bz2", "com"_"dotnet", "fileinfo", "gettext", "imap", "mbstring", "exif", "mysql", "mysql", "pdo_mysql", "pdo_sqlite", "pdo_sqlite3", "xmlrpc", "xsl". I agree OK everywhere, the same warnings will happen once more.

*************************************************
PHP Startup: bz2:Unable to initialize module
Module compile with module API=2013226
PHP compiled with module API=20100525
These options need to match
* OK*
*************************************************

*************
PHP Startup
*OK*
*************

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: RiggsFolly (Moderator)
Date: October 11, 2018 09:47AM

Ok, now it looks like you may have another `php.ini` file somewhere.

So do a search for `php.ini` and if you find one in any location other than inside the `\wamp\bin` folder delete them.

Also check that you do not have another PHP installed. Maybe if you tried installing PHP manually you didnt get rid of it. Also check that you do not have any folder in the windows PATH that points to any PHP folders, not even one inside the \wamp\bin\ folder.

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 11, 2018 04:56PM

php.ini is here only:

C:\wamp\bin\apache\Apache2.4.4\bin\php.ini
C:\wamp\bin\php\php5.4.16\php.ini
C:\wamp\bin\php\php5.6.17\php.ini

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: RiggsFolly (Moderator)
Date: October 11, 2018 05:30PM

Did you search all folder including the Windows folder?

---------------------------------------------------------------------------------------------
(Windows 10 Pro 64bit) (Wampserver 3.1.3 32bit & 64bit)
<Apache 2.4.29/2.2.31> <PHP 7.2/7.1/7.0/5.6/5.5/5.4> <MySQL 5.7.19/5.6.39/5.5.28>
<MariaDB 10.2.14> <phpMyAdmin4.8.1> <MySQL Workbench 6.3.10>

Read The Manuals Apache -- MySQL -- PHP -- phpMyAdmin
Get your Apache/MySQL/mariaDB/PHP ADDONs here from the WAMPServer alternate Repo
-X-X-X- Backup your MySQL databases regularly Here is How dont regret it later! Yes even when developing -X-X-X-

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 11, 2018 10:39PM

Yes, in another place 'php.ini' is not.

Options: ReplyQuote
Re: Upgraded PHP, MySQL to WAMP
Posted by: meda (---.96.broadband7.iol.cz)
Date: October 12, 2018 01:26AM

I changed in the libraries
'C:\wamp\bin\apache\Apache2.4.4\bin\php5ts.dll'
'C:\wamp\bin\apache\Apache2.4.4\bin\php5nsapi.dll':
20100525 -> 20131226.
Warning no longer appears, I will see if everything will work as it should.

Options: ReplyQuote
Pages: 12Next
Current Page: 1 of 2


Sorry, only registered users may post in this forum.